summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2020-03-14 01:44:15 +0100
committerJake2020-03-14 01:44:15 +0100
commit204fd2411b94668e05de5acdaa544eb25ecec547 (patch)
tree39f7d531bfb0d7e6d5869d662f155a8f871971ee
parentf6197e89df883a13ef6f2d30e8603dfd2c7004db (diff)
downloadaur-204fd2411b94668e05de5acdaa544eb25ecec547.tar.gz
Update to 1.10
-rw-r--r--.SRCINFO16
-rw-r--r--0001-workaround-configure-failure-due-to-boost-cmake.patch26
-rw-r--r--0002-cmake-python-link.patch29
-rw-r--r--PKGBUILD16
4 files changed, 11 insertions, 76 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7df4b7611e7..243f22ab7fec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dsview
pkgdesc = Client software that supports the DreamSourceLab logic analyzer
- pkgver = 1.01
- pkgrel = 2
+ pkgver = 1.10
+ pkgrel = 1
url = http://www.dreamsourcelab.com/
arch = i686
arch = x86_64
@@ -9,19 +9,15 @@ pkgbase = dsview
makedepends = boost
depends = boost-libs
depends = qt5-base
- depends = libsigrokdecode4dsl=1.01
- depends = libsigrok4dsl=1.01
+ depends = libsigrokdecode4dsl=1.10
+ depends = libsigrok4dsl=1.10
depends = fftw
- source = DSView-1.01.tar.gz::https://github.com/DreamSourceLab/DSView/archive/v1.01.tar.gz
+ source = DSView-1.10.tar.gz::https://github.com/DreamSourceLab/DSView/archive/v1.10.tar.gz
source = udev.rules
source = dsview.desktop
- source = 0001-workaround-configure-failure-due-to-boost-cmake.patch
- source = 0002-cmake-python-link.patch
- sha384sums = b8bf646f8c599cb8adfa2ab1363f36592a1ecb10b819617cecc970ac7a30b8d5ef912e9af5c1d55a9282478d8a55b80e
+ sha384sums = 6cd82ee9c729db48f86aa00c492eb7e18a8b444d3bd7a384fbd7433e24758d7190ef88082457111b752d28c28145d9a5
sha384sums = 4f7c463e0723e3cfd6ed146e0db6b44627065af077aaca9765b60c9347752e32032752f04883da89b9f65523ca5c28e8
sha384sums = 6c47f8b81858cfccc96a0e18dd56dbb23c72baa165650d145898eea8d8f3493a9179f7c8c9afd651ed99e713c9106238
- sha384sums = 338763e008464bebb1f11e62d3a4839d7af43c800f772be6d51a345f6e1e83fa4d5929c1e4b363dd9af2073dda420821
- sha384sums = b3c355692709a1d9f4a1712f963ab87b1437e8d40fe0bb43dbc433f29ff9b06cc630bff357d33e5da6a351bee9dbd98f
pkgname = dsview
diff --git a/0001-workaround-configure-failure-due-to-boost-cmake.patch b/0001-workaround-configure-failure-due-to-boost-cmake.patch
deleted file mode 100644
index cad84b020578..000000000000
--- a/0001-workaround-configure-failure-due-to-boost-cmake.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From bd4a58104007309a6bbf8b52d508232098d86438 Mon Sep 17 00:00:00 2001
-From: Cody P Schafer <dev@codyps.com>
-Date: Sun, 13 Oct 2019 12:22:39 -0400
-Subject: [PATCH] workaround configure failure due to boost cmake
-
----
- DSView/CMakeLists.txt | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/DSView/CMakeLists.txt b/DSView/CMakeLists.txt
-index 1a844a4..1787889 100755
---- a/DSView/CMakeLists.txt
-+++ b/DSView/CMakeLists.txt
-@@ -24,6 +24,9 @@ cmake_minimum_required(VERSION 2.8.6)
- include(FindPkgConfig)
- include(GNUInstallDirs)
-
-+# workaround 'Imported target "Boost::filesystem" includes non-existent
-+# path "/include"' error
-+set(Boost_NO_BOOST_CMAKE TRUE)
- set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/CMake")
-
- project(DSView)
---
-2.23.0
-
diff --git a/0002-cmake-python-link.patch b/0002-cmake-python-link.patch
deleted file mode 100644
index e55e2bfa4832..000000000000
--- a/0002-cmake-python-link.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From d5ad3518afd82c68af9a1e8364668c41c40341d1 Mon Sep 17 00:00:00 2001
-From: Abdelhak Bougouffa <abougouffa@fedoraproject.org>
-Date: Tue, 19 Nov 2019 15:14:15 +0100
-Subject: [PATCH] Add PythonLibs to link libraries in CMake, Fix #258
-
----
- DSView/CMakeLists.txt | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/DSView/CMakeLists.txt b/DSView/CMakeLists.txt
-index 1a844a4..16ef406 100755
---- a/DSView/CMakeLists.txt
-+++ b/DSView/CMakeLists.txt
-@@ -92,6 +92,7 @@ endif()
-
- find_package(Threads)
-
-+find_package(PythonLibs 3 EXACT)
- find_package(Boost 1.42 COMPONENTS filesystem system thread REQUIRED)
- find_package(libusb-1.0 REQUIRED)
- find_package(libzip REQUIRED)
-@@ -390,6 +391,7 @@ else()
- list(APPEND DSVIEW_LINK_LIBS ${PKGDEPS_LIBRARIES})
- endif()
-
-+list(APPEND DSVIEW_LINK_LIBS ${PYTHON_LIBRARIES})
-
- add_executable(${PROJECT_NAME}
- ${DSView_SOURCES}
diff --git a/PKGBUILD b/PKGBUILD
index e02b6c69296d..156a2174907f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,23 @@
# Contributor: Thomas Krug <t.krug@elektronenpumpe.de>
pkgname=dsview
-pkgver=1.01
-pkgrel=2
+pkgver=1.10
+pkgrel=1
pkgdesc="Client software that supports the DreamSourceLab logic analyzer"
arch=('i686' 'x86_64')
url="http://www.dreamsourcelab.com/"
license=('GPL3')
-depends=('boost-libs' 'qt5-base' "libsigrokdecode4dsl=${pkgver}" "libsigrok4dsl=${pkgver}" 'fftw')
+depends=('boost-libs' 'qt5-base' "libsigrokdecode4dsl>=${pkgver}" "libsigrok4dsl>=${pkgver}" 'fftw')
makedepends=('boost')
source=(
"DSView-$pkgver.tar.gz::https://github.com/DreamSourceLab/DSView/archive/v${pkgver}.tar.gz"
'udev.rules'
'dsview.desktop'
- '0001-workaround-configure-failure-due-to-boost-cmake.patch'
- '0002-cmake-python-link.patch'
)
-sha384sums=('b8bf646f8c599cb8adfa2ab1363f36592a1ecb10b819617cecc970ac7a30b8d5ef912e9af5c1d55a9282478d8a55b80e'
+sha384sums=('6cd82ee9c729db48f86aa00c492eb7e18a8b444d3bd7a384fbd7433e24758d7190ef88082457111b752d28c28145d9a5'
'4f7c463e0723e3cfd6ed146e0db6b44627065af077aaca9765b60c9347752e32032752f04883da89b9f65523ca5c28e8'
- '6c47f8b81858cfccc96a0e18dd56dbb23c72baa165650d145898eea8d8f3493a9179f7c8c9afd651ed99e713c9106238'
- '338763e008464bebb1f11e62d3a4839d7af43c800f772be6d51a345f6e1e83fa4d5929c1e4b363dd9af2073dda420821'
- 'b3c355692709a1d9f4a1712f963ab87b1437e8d40fe0bb43dbc433f29ff9b06cc630bff357d33e5da6a351bee9dbd98f')
+ '6c47f8b81858cfccc96a0e18dd56dbb23c72baa165650d145898eea8d8f3493a9179f7c8c9afd651ed99e713c9106238')
_wdir() {
cd "$srcdir/DSView-$pkgver/DSView"
@@ -31,8 +27,6 @@ _wdir() {
prepare() {
cd "$srcdir/DSView-$pkgver"
- patch -Np1 -i "$srcdir"/'0001-workaround-configure-failure-due-to-boost-cmake.patch'
- patch -Np1 -i "$srcdir"/'0002-cmake-python-link.patch'
cd DSView
sed -i 's#install(FILES icons/logo.png DESTINATION share/${PROJECT_NAME} RENAME logo.png)##;