summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2016-08-12 01:53:17 -0700
committerAnatol Pomozov2016-08-12 01:57:20 -0700
commitc86c742f9b01aa8c068d39896b05615ab4804b6c (patch)
treee789d212d67b49b198d4befff8f8f4aef6cc68f4
parent415633c952aae23cb006b80cefae9b7caed7cbbb (diff)
downloadaur-c86c742f9b01aa8c068d39896b05615ab4804b6c.tar.gz
updpkg
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
-rw-r--r--Use-usr-share-for-resource-files-bin-folder-is-for-b.patch77
-rw-r--r--dsview.desktop9
4 files changed, 7 insertions, 108 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56b6d5600abb..c5702832d3b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun May 1 15:49:08 UTC 2016
+# Fri Aug 12 08:53:12 UTC 2016
pkgbase = dsview-git
pkgdesc = GUI programe for supporting various instruments from DreamSourceLab, including logic analyzer, oscilloscope, etc.
- pkgver = 0.95.r8.gaad5257
+ pkgver = 0.95.r40.g7665ade
pkgrel = 1
url = http://www.dreamsourcelab.com/
arch = i686
@@ -13,15 +13,11 @@ pkgbase = dsview-git
depends = boost-libs
depends = qt5-base
depends = libsigrok4dsl-git
- depends = libsigrokdecode-git
+ depends = libsigrokdecode4dsl-git
source = git://github.com/DreamSourceLab/DSView#branch=develop
- source = Use-usr-share-for-resource-files-bin-folder-is-for-b.patch
source = udev.rules
- source = dsview.desktop
sha1sums = SKIP
- sha1sums = 80beaa22bab87925a38a9be56abdb7cb77d4ac5e
sha1sums = 50f23061fcd03e0aafdefb3b676f1846c036c856
- sha1sums = 96d3a0168f392af655e2b309711d7810ad3c022f
pkgname = dsview-git
diff --git a/PKGBUILD b/PKGBUILD
index b05ba386d9cc..0f5b1f80c271 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,25 @@
# Contributor: Thomas Krug <t.krug@elektronenpumpe.de>
pkgname=dsview-git
-pkgver=0.95.r8.gaad5257
+pkgver=0.95.r40.g7665ade
pkgrel=1
pkgdesc='GUI programe for supporting various instruments from DreamSourceLab, including logic analyzer, oscilloscope, etc.'
arch=(i686 x86_64)
url='http://www.dreamsourcelab.com/'
license=(GPL3)
# Upstream added VCS dependency to libsigrokdecode :/
-depends=(boost-libs qt5-base libsigrok4dsl-git libsigrokdecode-git)
+depends=(boost-libs qt5-base libsigrok4dsl-git libsigrokdecode4dsl-git)
makedepends=(boost cmake)
source=(git://github.com/DreamSourceLab/DSView#branch=develop
- Use-usr-share-for-resource-files-bin-folder-is-for-b.patch
- udev.rules
- dsview.desktop)
+ udev.rules)
sha1sums=('SKIP'
- '80beaa22bab87925a38a9be56abdb7cb77d4ac5e'
- '50f23061fcd03e0aafdefb3b676f1846c036c856'
- '96d3a0168f392af655e2b309711d7810ad3c022f')
+ '50f23061fcd03e0aafdefb3b676f1846c036c856')
pkgver() {
cd DSView
git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
-prepare() {
- cd DSView
- patch -p1 < "$srcdir/Use-usr-share-for-resource-files-bin-folder-is-for-b.patch"
-}
-
build() {
cd DSView/DSView
@@ -43,7 +34,5 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 icons/logo_color.png "$pkgdir/usr/share/pixmaps/dsview.png"
-
- install -Dm644 "$srcdir/dsview.desktop" "$pkgdir/usr/share/applications/dsview.desktop"
install -Dm644 "$srcdir/udev.rules" "$pkgdir/usr/lib/udev/rules.d/20-dsview.rules"
}
diff --git a/Use-usr-share-for-resource-files-bin-folder-is-for-b.patch b/Use-usr-share-for-resource-files-bin-folder-is-for-b.patch
deleted file mode 100644
index 001f9ca87aae..000000000000
--- a/Use-usr-share-for-resource-files-bin-folder-is-for-b.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-From 3ccc5276eefd927c6e999b22fb6cc997b79fc8a4 Mon Sep 17 00:00:00 2001
-From: Anatol Pomozov <anatol.pomozov@gmail.com>
-Date: Mon, 14 Dec 2015 09:05:10 -0800
-Subject: [PATCH] Use /usr/share for resource files bin folder is for
- binaries.
-
----
- DSView/CMakeLists.txt | 30 +++++++++++++++---------------
- DSView/pv/devicemanager.cpp | 5 +++++
- 2 files changed, 20 insertions(+), 15 deletions(-)
-
-diff --git a/DSView/CMakeLists.txt b/DSView/CMakeLists.txt
-index c5703c6..eb8bbc0 100644
---- a/DSView/CMakeLists.txt
-+++ b/DSView/CMakeLists.txt
-@@ -352,21 +352,21 @@ set_target_properties(${PROJECT_NAME} PROPERTIES INSTALL_RPATH "/usr/local/lib")
-
- # Install the executable.
- install(TARGETS ${PROJECT_NAME} DESTINATION bin/)
--install(FILES res/DSLogic.fw DESTINATION bin/res/)
--install(FILES res/DSLogic33.bin DESTINATION bin/res/)
--install(FILES res/DSLogic50.bin DESTINATION bin/res/)
--install(FILES res/DSLogicPro.fw DESTINATION bin/res/)
--install(FILES res/DSLogicPro.bin DESTINATION bin/res/)
--install(FILES res/DSCope.fw DESTINATION bin/res/)
--install(FILES res/DSCope.bin DESTINATION bin/res/)
--install(FILES res/DSLogic0.dsc DESTINATION bin/res/)
--install(FILES res/DSLogic0.def.dsc DESTINATION bin/res/)
--install(FILES res/DSLogic1.dsc DESTINATION bin/res/)
--install(FILES res/DSLogic1.def.dsc DESTINATION bin/res/)
--install(FILES res/DSLogic2.dsc DESTINATION bin/res/)
--install(FILES res/DSLogic2.def.dsc DESTINATION bin/res/)
--install(FILES res/DSCope1.dsc DESTINATION bin/res/)
--install(FILES res/DSCope1.def.dsc DESTINATION bin/res/)
-+install(FILES res/DSLogic.fw DESTINATION share/dsview/)
-+install(FILES res/DSLogic33.bin DESTINATION share/dsview/)
-+install(FILES res/DSLogic50.bin DESTINATION share/dsview/)
-+install(FILES res/DSLogicPro.fw DESTINATION share/dsview/)
-+install(FILES res/DSLogicPro.bin DESTINATION share/dsview/)
-+install(FILES res/DSCope.fw DESTINATION share/dsview/)
-+install(FILES res/DSCope.bin DESTINATION share/dsview/)
-+install(FILES res/DSLogic0.dsc DESTINATION share/dsview/)
-+install(FILES res/DSLogic0.def.dsc DESTINATION share/dsview/)
-+install(FILES res/DSLogic1.dsc DESTINATION share/dsview/)
-+install(FILES res/DSLogic1.def.dsc DESTINATION share/dsview/)
-+install(FILES res/DSLogic2.dsc DESTINATION share/dsview/)
-+install(FILES res/DSLogic2.def.dsc DESTINATION share/dsview/)
-+install(FILES res/DSCope1.dsc DESTINATION share/dsview/)
-+install(FILES res/DSCope1.def.dsc DESTINATION share/dsview/)
-
- #===============================================================================
- #= Packaging (handled by CPack)
-diff --git a/DSView/pv/devicemanager.cpp b/DSView/pv/devicemanager.cpp
-index 066af64..d6406d9 100644
---- a/DSView/pv/devicemanager.cpp
-+++ b/DSView/pv/devicemanager.cpp
-@@ -103,12 +103,17 @@ std::list<boost::shared_ptr<device::DevInst> > DeviceManager::driver_scan(
-
- // Check If DSL hardware driver
- if (strncmp(driver->name, "virtual", 7)) {
-+ /*
- QDir dir(QCoreApplication::applicationDirPath());
- if (!dir.cd("res"))
- return driver_devices;
- QString str = dir.absolutePath() + "/";
- QString str_utf8 = QString::fromLocal8Bit(str.toLocal8Bit());
- strcpy(config_path, str_utf8.toUtf8().data());
-+ */
-+ // dirty
-+ // maybe use QStandardPaths::standardLocations(QStandardPaths::AppDataLocation);
-+ strcpy(config_path, "/usr/share/dsview/");
- }
-
- // Do the scan
---
-2.6.4
-
diff --git a/dsview.desktop b/dsview.desktop
deleted file mode 100644
index cbc24d0032f9..000000000000
--- a/dsview.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Exec=DSView
-Name=DSView
-GenericName=Logic Analyzer
-Comment=DreamStudio Logic Analyzer
-Icon=dsview
-Type=Application
-Terminal=false
-Categories=Development