summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-04-09 01:42:23 +0200
committerCarsten Teibes2014-04-09 01:42:23 +0200
commit09539552f46ae57b3f8a48fb2539822e7724bdfc (patch)
tree55528925f44c441113e251e310ea5eb60ad342fc
downloadaur-09539552f46ae57b3f8a48fb2539822e7724bdfc.tar.gz
[add] dswifi 0.3.16
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0caae74bfe6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dswifi
+ pkgdesc = Library for using the wireless capabilities of the Nintendo DS for homebrew development
+ pkgver = 0.3.16
+ pkgrel = 1
+ url = http://www.akkit.org/dswifi/
+ arch = any
+ license = custom
+ depends = libnds
+ options = !strip
+ options = libtool
+ options = staticlibs
+ source = http://downloads.sourceforge.net/sourceforge/devkitpro/dswifi-src-0.3.16.tar.bz2
+ sha256sums = 5602a0c2840a95020ff6113ec982bfdbc7c3d4466b94d0c8f9026c7d4b636b33
+
+pkgname = dswifi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2f1f8a0a671
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Contributor: Gerardo Marset <gammer1994@gmail.com>
+# Contributor: Aaron Lindsay <aerial9@gmail.com>
+# Contributor: Vithon <ratm@archlinux.us>
+# Contributor: Alain
+
+pkgname=dswifi
+pkgver=0.3.16
+pkgrel=1
+pkgdesc="Library for using the wireless capabilities of the Nintendo DS for homebrew development"
+license=('custom')
+arch=('any')
+url="http://www.akkit.org/dswifi/"
+depends=('libnds')
+source=("http://downloads.sourceforge.net/sourceforge/devkitpro/$pkgname-src-$pkgver.tar.bz2")
+sha256sums=('5602a0c2840a95020ff6113ec982bfdbc7c3d4466b94d0c8f9026c7d4b636b33')
+options=(!strip libtool staticlibs)
+
+build() {
+ source /etc/profile.d/devkitarm.sh
+
+ make
+}
+
+package() {
+ export DEVKITPRO="$pkgdir/opt/devkitpro"
+
+ install -d "$DEVKITPRO/libnds"
+ make install
+ # license
+ install -Dm644 dswifi_license.txt "$pkgdir"/usr/share/licenses/dswifi/dswifi_license.txt
+}