aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaoyang Zhang2021-10-07 16:07:51 +0800
committerGaoyang Zhang2021-10-07 16:07:51 +0800
commit5504693686d8177ff210452fceb7372afa2f874a (patch)
tree93c7b8d778e4ff5879206c4a39a45337d08e3608
downloadaur-5504693686d8177ff210452fceb7372afa2f874a.tar.gz
Add PKGBUILD and .SRCINFO for dt-0.1.0-1
Signed-off-by: Gaoyang Zhang <gy@blurgy.xyz>
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD49
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61cd88cc672d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dt
+ pkgdesc = Syncing dotfiles and more
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/blurgyy/dt
+ arch = any
+ license = MIT OR Apache 2.0
+ makedepends = curl
+ makedepends = rustup
+ depends = cargo
+ provides = dt-cli
+ conflicts = dt-git
+ conflicts = dt-bin
+ source = https://github.com/blurgyy/dt/archive/refs/tags/v0.1.0.tar.gz
+ sha256sums = 9b4cea5f092194793a624ebc3ece43f84fb0daaeba0b7e9200b9982e32679f81
+
+pkgname = dt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56a30f31ad6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Gaoyang Zhang <gy@blurgy.xyz>
+pkgname=dt
+pkgver=0.1.0
+pkgrel=1
+epoch=
+pkgdesc="Syncing dotfiles and more"
+arch=("any")
+url="https://github.com/blurgyy/dt"
+license=('MIT OR Apache 2.0')
+groups=()
+depends=(cargo)
+makedepends=(
+ curl
+ rustup
+)
+checkdepends=()
+optdepends=()
+provides=("dt-cli")
+conflicts=("dt-git" "dt-bin")
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/blurgyy/dt/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=("9b4cea5f092194793a624ebc3ece43f84fb0daaeba0b7e9200b9982e32679f81")
+noextract=()
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --bin=dt-cli --release --all-features
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test --release --all-features
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "target/release/dt-cli" "$pkgdir/usr/bin/dt-cli"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/dt/LICENSE"
+}