summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Lane2015-07-23 12:45:17 +0100
committerJohn Lane2015-07-23 12:48:14 +0100
commit3cd106b6a357d5e958baf2036b1ac15374891a62 (patch)
treef40c9831251b2010a442e7600b566dd4b7cf13b6
downloadaur-3cd106b6a357d5e958baf2036b1ac15374891a62.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..928011cbbd2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dtach-git
+ pkgdesc = emulates the detach feature of screen
+ pkgver = r40.c794d06
+ pkgrel = 1
+ url = http://dtach.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ provides = dtach
+ conflicts = dtach
+ source = dtach-git::git+https://github.com/crigler/dtach.git
+ md5sums = SKIP
+
+pkgname = dtach-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..440c36f17ade
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+dtach-git
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cb6dda8b6a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id$
+# Maintainer: John Lane <archlinux@jelmail.com>
+# Contributor: Chris Brannon <cmbrannon79@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Adam Vogt <vogt.adam@gmail.com>
+
+pkgname=dtach-git
+pkgver=r40.c794d06
+pkgrel=1
+pkgdesc="emulates the detach feature of screen"
+arch=('i686' 'x86_64')
+url="http://dtach.sourceforge.net/"
+license=('GPL')
+depends=('glibc')
+provides=('dtach')
+conflicts=('dtach')
+source=(${pkgname}::git+https://github.com/crigler/dtach.git)
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ ./configure CFLAGS="$CFLAGS -Wno-unused-result" --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -Dm755 dtach "${pkgdir}/usr/bin/dtach"
+ install -Dm644 dtach.1 "${pkgdir}/usr/share/man/man1/dtach.1"
+}
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+# vim:set ts=2 sw=2 et: