summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLes De Ridder2016-11-08 04:49:37 +0100
committerLes De Ridder2016-11-08 04:49:37 +0100
commita349cecdda74424ac3b6f3b258d59ed19f3ceac2 (patch)
treee625b233ecbc05f70ce962fb43aa1d11e2c9dd4e
downloadaur-a349cecdda74424ac3b6f3b258d59ed19f3ceac2.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc90f80b6657
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = dtagfs-git
+ pkgdesc = Tag-based FUSE virtual file system
+ pkgver = 0.1.0.r0.ga141d74
+ pkgrel = 1
+ url = https://git.fuwafuwa.moe/lesderid/dtagfs
+ arch = i386
+ arch = x86_64
+ license = custom:NCSA
+ makedepends = git
+ makedepends = dub
+ makedepends = d-compiler
+ depends = fuse
+ depends = exempi
+ provides = dtagfs
+ conflicts = dtagfs
+ source = git+https://git.fuwafuwa.moe/lesderid/dtagfs
+ md5sums = SKIP
+
+pkgname = dtagfs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..916981223c8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Les De Ridder <aur@lesderid.net>
+
+_pkgname=dtagfs
+pkgname=dtagfs-git
+pkgver=0.1.0.r0.ga141d74
+pkgrel=1
+pkgdesc="Tag-based FUSE virtual file system"
+arch=('i386' 'x86_64')
+url="https://git.fuwafuwa.moe/lesderid/dtagfs"
+license=('custom:NCSA')
+depends=('fuse' 'exempi')
+makedepends=('git' 'dub' 'd-compiler')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=('git+https://git.fuwafuwa.moe/lesderid/dtagfs')
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ dub build -b=release
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+
+ mkdir -p $pkgdir/usr/bin/
+ cp dtagfs $pkgdir/usr/bin/dtagfs
+ ln -s /usr/bin/dtagfs $pkgdir/usr/bin/mount.fuse.dtagfs
+
+ mkdir -p $pkgdir/usr/share/licenses/$_pkgname/
+ cp LICENSE $pkgdir/usr/share/licenses/$_pkgname/LICENSE
+}
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}