summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Tiá2016-03-05 12:48:08 -0600
committerJavier Tiá2016-03-05 12:48:08 -0600
commit633701e75dd6805b8e80bfb34218474df16446e0 (patch)
treee1b5fe06e465a959fc2ce184dac825bc1f1ef8c7
downloadaur-633701e75dd6805b8e80bfb34218474df16446e0.tar.gz
Bump up dtags v2.0.0-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
-rw-r--r--dtags.install19
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7bbe8f9ee9b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat Mar 5 18:45:07 UTC 2016
+pkgbase = dtags
+ pkgdesc = Directory Tags for Lazy Programmers
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/joowani/dtags
+ install = dtags.install
+ arch = any
+ license = MIT
+ depends = python
+ provides = dtags=2.0.0
+ source = https://github.com/joowani/dtags/archive/2.0.0.tar.gz
+ sha256sums = a814aa935d6334074a0f416588f55883648b239f4d92b5cf71ea5bacffd4a0b2
+
+pkgname = dtags
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fbd553193d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Javier Tiá <javier dot tia at gmail dot com>
+
+_name=dtags
+pkgname="${_name}"
+pkgver=2.0.0
+pkgrel=1
+pkgdesc='Directory Tags for Lazy Programmers'
+url='https://github.com/joowani/dtags'
+arch=('any')
+license=('MIT')
+depends=('python')
+provides=("${_name}=${pkgver}")
+install="${pkgname}.install"
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=('a814aa935d6334074a0f416588f55883648b239f4d92b5cf71ea5bacffd4a0b2')
+
+# Enable for tests
+# check() {
+ # cd "${srcdir}/${_name}-${pkgver}"
+ # python setup.py check
+# }
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ft=sh ts=2 sw=2 et:
diff --git a/dtags.install b/dtags.install
new file mode 100644
index 000000000000..3c73e942e2f3
--- /dev/null
+++ b/dtags.install
@@ -0,0 +1,19 @@
+post_install() {
+ cat << EOF
+
+To complete the installation, place the following line in your shell config:
+
+ For zsh, place in ~/.zshrc:
+
+ command -v dtags > /dev/null 2>&1 && . <(dtags shell zsh)
+
+ For bash, place in ~/.bashrc
+
+ command -v dtags > /dev/null 2>&1 && . <(dtags shell bash)
+
+ For fish, place in ~/.config/fish/config.fish:
+
+ command -v dtags > /dev/null 2>&1; and dtags shell fish | source
+
+EOF
+}