aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavion2018-12-25 09:06:53 +1100
committerXavion2018-12-25 09:06:53 +1100
commita912b6b7a773b7200a0fab22daa568c44c672ec5 (patch)
tree2ee60203974f30dc68e16d878e8a8635d2638078
downloadaur-a912b6b7a773b7200a0fab22daa568c44c672ec5.tar.gz
Re-adding deleted package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--README19
-rwxr-xr-xdtboost.install15
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e7e8c7569f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dtboost
+ pkgdesc = A daemon that changes priority (CPU and disk I/O) and limits CPU usage of your applications on the fly
+ pkgver = 1.6.15
+ pkgrel = 1
+ url = http://code.google.com/p/dtboost/
+ install = dtboost.install
+ arch = any
+ license = GPL3
+ depends = python2
+ optdepends = cpulimit: CPU use limit per process
+ backup = etc/dtboost.conf
+ source = https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/dtboost/dtboost-1.6.15.tgz
+ sha1sums = cb8e92515dde26f4cbe84f05ec0c86776dd5b46e
+
+pkgname = dtboost
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ff7dad2825d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+# Contributor: Tibor Bamhor <tiborb95 at gmail.com>
+
+pkgname=dtboost
+pkgver=1.6.15
+pkgrel=1
+pkgdesc="A daemon that changes priority (CPU and disk I/O) and limits CPU usage of your applications on the fly"
+url="http://code.google.com/p/${pkgname}/"
+license=("GPL3")
+arch=("any")
+depends=("python2")
+optdepends=("cpulimit: CPU use limit per process")
+install="${pkgname}.install"
+backup=("etc/${pkgname}.conf")
+source=(https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${pkgname}/${pkgname}-${pkgver}.tgz)
+
+package() {
+ cd ${srcdir}/${pkgname}
+
+ # Directories
+ install -d "${pkgdir}"/usr/{share/${pkgname}/,lib/systemd/system/} "${pkgdir}"/etc/
+
+ install -m 744 ${srcdir}/${pkgname}/${pkgname}.py ${pkgdir}/usr/share/${pkgname}/
+ install -m 644 ${srcdir}/${pkgname}/${pkgname}.conf ${pkgdir}/etc/
+ #install -m 744 ${srcdir}/${pkgname}/${pkgname}.initscript ${pkgdir}/etc/rc.d/${pkgname}
+ install -m 644 ${srcdir}/${pkgname}/${pkgname}.service ${pkgdir}/usr/lib/systemd/system/
+}
+
+sha1sums=('cb8e92515dde26f4cbe84f05ec0c86776dd5b46e')
diff --git a/README b/README
new file mode 100644
index 000000000000..7249417e5dd7
--- /dev/null
+++ b/README
@@ -0,0 +1,19 @@
+Notes specific to ArchLinux
+
+(read also Readme in source tarbal - you can find it in src/ directory....)
+
+
+Please note, that you have to edit configuration file /etc/dtboost.conf
+to list critical applications you want to reprioritize, and few other things.
+
+After installation try to run the script manually to watch what it prints out:
+$/usr/local/dtboost/dtboost.py
+that way it will run in verbose mode. Init script starts it in quiet mode.
+
+you can see some logs in /var/log/user.log (only if run in quit mode - 'dtboost.py -q'), try:
+$grep dtboost /var/log/user.log
+
+More info also at:
+http://code.google.com/p/dtboost/wiki/dtboostIntroduction
+
+Be tolerant for this is new project, feedback welcomed at tiborb95 at gmail.com \ No newline at end of file
diff --git a/dtboost.install b/dtboost.install
new file mode 100755
index 000000000000..dc20f4c505b6
--- /dev/null
+++ b/dtboost.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo "Please consider review of /etc/dtboost.conf, read comments included there"
+ echo "If you are using systemd, you need to enable dtboost like:"
+ echo "'systemctl enable dtboost.service' and/or 'systemctl start dtboost'"
+ #echo "If you are still using initscripts instead, you need to have dtboost among deamons in /etc/rc.conf, like:"
+ #echo "DAEMONS=(aaaa bbbb dtboost)"
+
+ test -e /etc/dtboost.conf.pacnew && chmod 644 /etc/dtboost.conf.pacnew
+ chmod 644 /etc/dtboost.conf
+}
+
+post_upgrade() {
+ post_install
+ #/bin/true
+}