summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Arlott2021-08-20 08:28:58 +0100
committerSimon Arlott2021-08-20 08:28:58 +0100
commit202dfd7552c7169553fe30e01646bcd043f833b1 (patch)
treeecb34ba929b0ffb68d94632032c064c53e164319
parent128ba8b5b2b779724814cbc45551431da20f8cee (diff)
downloadaur-202dfd7552c7169553fe30e01646bcd043f833b1.tar.gz
Split up makefile targets
-rw-r--r--GNUmakefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/GNUmakefile b/GNUmakefile
index 1e08cc79b1ae..6d5a891e0094 100644
--- a/GNUmakefile
+++ b/GNUmakefile
@@ -1,7 +1,12 @@
-.PHONY: all
+.PHONY: aur metadata pkg
-all:
+pkg:
+ makepkg
+
+metadata:
mkdir -p src
cd src && updpkgsums ../PKGBUILD
makepkg --printsrcinfo > .SRCINFO
- makepkg
+
+aur:
+ git push aur arch:master