summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Arlott2024-04-20 15:59:21 +0100
committerSimon Arlott2024-04-20 16:01:09 +0100
commit6045ed1d595db7154dc9ff87d35448a54a02366b (patch)
tree202fa0f2e2e62a263a22a9840b246696284449d0
parent0c985e3ecec55d558251fbfc3ba8b81feefccdf0 (diff)
downloadaur-6045ed1d595db7154dc9ff87d35448a54a02366b.tar.gz
New version 1.1.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c33259c0408..6668f9de38bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dtee
pkgdesc = Run a program with standard output and standard error copied to files
- pkgver = 1.1.0
+ pkgver = 1.1.1
pkgrel = 1
url = https://dtee.readthedocs.io/
arch = x86_64
@@ -15,13 +15,12 @@ pkgbase = dtee
makedepends = python-sphinx
depends = boost-libs
depends = libboost_program_options.so
- depends = libboost_filesystem.so
options = zipman
options = lto
- source = https://dtee.bin.uuid.uk/source/dtee-1.1.0.tar.gz
- source = https://dtee.bin.uuid.uk/source/dtee-1.1.0.tar.gz.asc
+ source = https://dtee.bin.uuid.uk/source/dtee-1.1.1.tar.gz
+ source = https://dtee.bin.uuid.uk/source/dtee-1.1.1.tar.gz.asc
validpgpkeys = 47849A12DAF9BD2AF5505FBB4FF886F318206BD9
- sha256sums = 7ed65431e51493fbdb16e6d1d89cd852d4d265e69b1414c42ed23e6852e6b51f
+ sha256sums = f1de814533861b591c41945c2c728c029e5db2b25bfcb5366601f9cad52eb5f6
sha256sums = SKIP
pkgname = dtee
diff --git a/PKGBUILD b/PKGBUILD
index d997b8f62727..938d6dc60b4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: Simon Arlott <arch@sa.me.uk>
pkgname=dtee
-pkgver=1.1.0
+pkgver=1.1.1
pkgrel=1
pkgdesc="Run a program with standard output and standard error copied to files"
arch=('x86_64')
url="https://dtee.readthedocs.io/"
license=('GPL3')
-depends=('boost-libs' 'libboost_program_options.so' 'libboost_filesystem.so')
+depends=('boost-libs' 'libboost_program_options.so')
makedepends=('boost' 'meson' 'ninja' 'python-sphinx')
checkdepends=('bash' 'coreutils' 'diffutils' 'findutils')
options=('zipman' 'lto')
source=("https://dtee.bin.uuid.uk/source/${pkgname}-${pkgver}.tar.gz"
"https://dtee.bin.uuid.uk/source/${pkgname}-${pkgver}.tar.gz.asc")
noextract=()
-sha256sums=('7ed65431e51493fbdb16e6d1d89cd852d4d265e69b1414c42ed23e6852e6b51f'
+sha256sums=('f1de814533861b591c41945c2c728c029e5db2b25bfcb5366601f9cad52eb5f6'
'SKIP')
validpgpkeys=('47849A12DAF9BD2AF5505FBB4FF886F318206BD9')
build() {
cd "$pkgname-$pkgver"
rm -rf build/arch
- GIT_DIR="${srcdir}/.git" meson --prefix /usr --buildtype=plain build/arch --unity on
+ GIT_DIR="${srcdir}/.git" meson setup --prefix /usr --buildtype=plain build/arch --unity on
GIT_DIR="${srcdir}/.git" ninja -C build/arch
}
@@ -32,6 +32,4 @@ check() {
package() {
cd "$pkgname-$pkgver"
DESTDIR="$pkgdir/" GIT_DIR="${srcdir}/.git" ninja -C build/arch install
- ln -sf dtee "${pkgdir}/usr/bin/cronty"
- ln -sf dtee.1 "${pkgdir}/usr/share/man/man1/cronty.1"
}