summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2022-12-28 16:51:09 +0800
committerjustforlxz2022-12-28 16:51:09 +0800
commitaa366d7e9ca8c5e0802c3e45de9bfb74f1905455 (patch)
tree46ad9f5d72bd51985076183ec4ab8607c26b640c
parent48f8eeee2fa818bfeac4f9a8146c6cef703f3cd5 (diff)
downloadaur-aa366d7e9ca8c5e0802c3e45de9bfb74f1905455.tar.gz
update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4172cde478b5..1e19a4b680ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dtkcommon-git
pkgdesc = DTK common modules
- pkgver = 5.5.23.r18.gb7830a3
+ pkgver = 5.6.3.r1.g3781d33
pkgrel = 1
url = https://github.com/linuxdeepin/dtkcommon
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = dtkcommon-git
makedepends = cmake
makedepends = ninja
conflicts = dtkcommon
- source = dtkcommon.tar.gz::https://github.com/linuxdeepin/dtkcommon/archive/b7830a3221c99cc7715675ecfaed2a04388f8af6.tar.gz
- sha512sums = ea89005ac7de534a7d63dce9dda00aa485cdae3e337997cea01a8b624aad3c6f0676a8bc1127dbfc251fee4b6363deb10a3bb4b36366420aee8be97d2b34f17d
+ source = dtkcommon-git::git+https://github.com/linuxdeepin/dtkcommon
+ sha512sums = SKIP
pkgname = dtkcommon-git
diff --git a/PKGBUILD b/PKGBUILD
index 448c96f07e64..3eed2a84b689 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,7 @@
# Maintainer: justforlxz <justforlxz@gmail.com>
pkgname=dtkcommon-git
-_pkgname=dtkcommon
-_commit=b7830a3221c99cc7715675ecfaed2a04388f8af6
-pkgver=5.5.23.r18.gb7830a3
+pkgver=5.6.3.r1.g3781d33
pkgrel=1
pkgdesc='DTK common modules'
arch=('x86_64' 'aarch64')
@@ -14,19 +12,24 @@ makedepends=('git' 'qt5-tools' 'gtest' 'gmock' 'cmake' 'ninja')
conflicts=('dtkcommon')
providers=('dtkcommon')
groups=('deepin-git')
-source=("$_pkgname.tar.gz::https://github.com/linuxdeepin/dtkcommon/archive/$_commit.tar.gz")
-sha512sums=('ea89005ac7de534a7d63dce9dda00aa485cdae3e337997cea01a8b624aad3c6f0676a8bc1127dbfc251fee4b6363deb10a3bb4b36366420aee8be97d2b34f17d')
+source=("$pkgname::git+https://github.com/linuxdeepin/dtkcommon")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
build() {
- cd $_pkgname-$_commit
- cmake -GNinja \
+ cd $pkgname
+ cmake -B build -GNinja \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
-DLINUXNAME="archlinux" \
-DCMAKE_INSTALL_PREFIX=/usr
- ninja
+ cmake --build build
}
package() {
- cd $_pkgname-$_commit
+ cd $pkgname/build
DESTDIR="$pkgdir" ninja install
}