summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorharuyukilxz2018-07-13 18:31:48 +0800
committerharuyukilxz2018-07-13 18:31:48 +0800
commit232429c5fba41bd43c1b416e0ebbdd9d66887478 (patch)
tree6554cd6765277605528414c32585132c53d3acd6
downloadaur-232429c5fba41bd43c1b416e0ebbdd9d66887478.tar.gz
update
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD32
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75d8383b60f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = dtkcore-git
+ pkgdesc = DTK core modules
+ pkgver = 2.0.8.1.r1.57ec78b
+ pkgrel = 1
+ url = https://github.com/linuxdeepin/dtkcore
+ arch = x86_64
+ license = GPL3
+ makedepends = qt5-tools
+ depends = deepin-qt-dbus-factory
+ depends = dtkcore
+ depends = librsvg
+ depends = qt5-multimedia
+ depends = qt5-svg
+ depends = qt5-x11extras
+ depends = startup-notification
+ provides = dtkcore
+ conflicts = deepin-tool-kit<0.3.4
+ conflicts = dtkcore
+ replaces = deepin-tool-kit
+ options = debug
+ source = git+https://github.com/linuxdeepin/dtkcore.git
+ sha512sums = SKIP
+
+pkgname = dtkcore-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cab6a9f7aab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id$
+# Maintainer: Haruyuki lxz <lxz@ilxz.me>
+
+pkgname=dtkcore-git
+pkgver=2.0.8.1.r1.57ec78b
+pkgrel=1
+pkgdesc='DTK core modules'
+arch=('x86_64')
+url="https://github.com/linuxdeepin/dtkcore"
+license=('GPL3')
+depends=('deepin-qt-dbus-factory' 'dtkcore' 'librsvg' 'qt5-multimedia' 'qt5-svg' 'qt5-x11extras'
+ 'startup-notification')
+provides=('dtkcore')
+makedepends=('qt5-tools')
+replaces=('deepin-tool-kit')
+conflicts=('deepin-tool-kit<0.3.4' 'dtkcore')
+options=('debug')
+source=("git+https://github.com/linuxdeepin/dtkcore.git")
+sha512sums=('SKIP')
+
+build() {
+ cd dtkcore
+ git checkout 57ec78b
+ LDFLAGS=${LDFLAGS/,-z,now/}
+ qmake-qt5 PREFIX=/usr
+ make -j4
+}
+
+package() {
+ cd dtkcore
+ make INSTALL_ROOT="$pkgdir" install
+}