summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang, DingYuan2020-08-07 19:15:18 +0800
committerZhang, DingYuan2020-08-07 19:15:18 +0800
commit6d71c5933ae588940cf862fc00d501d20151a3e5 (patch)
treebfe11d0ee9290ddf88dc64c47ddd898f9e86c589
parent232429c5fba41bd43c1b416e0ebbdd9d66887478 (diff)
downloadaur-6d71c5933ae588940cf862fc00d501d20151a3e5.tar.gz
update
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD30
2 files changed, 27 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75d8383b60f3..b29eb7ce7c6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
pkgbase = dtkcore-git
pkgdesc = DTK core modules
- pkgver = 2.0.8.1.r1.57ec78b
+ pkgver = 5.2.2.3.r0.g3241d4d
pkgrel = 1
+ epoch = 1
url = https://github.com/linuxdeepin/dtkcore
arch = x86_64
- license = GPL3
+ license = LGPL3
+ makedepends = git
makedepends = qt5-tools
- depends = deepin-qt-dbus-factory
- depends = dtkcore
- depends = librsvg
- depends = qt5-multimedia
- depends = qt5-svg
- depends = qt5-x11extras
- depends = startup-notification
+ depends = dconf
+ depends = deepin-desktop-base
+ depends = python
+ depends = gsettings-qt
+ depends = lshw
provides = dtkcore
- conflicts = deepin-tool-kit<0.3.4
conflicts = dtkcore
- replaces = deepin-tool-kit
- options = debug
- source = git+https://github.com/linuxdeepin/dtkcore.git
+ replaces = dtkcore
+ source = git://github.com/linuxdeepin/dtkcore.git
sha512sums = SKIP
pkgname = dtkcore-git
diff --git a/PKGBUILD b/PKGBUILD
index 3cab6a9f7aab..654cd4fc3752 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
-# $Id$
# Maintainer: Haruyuki lxz <lxz@ilxz.me>
pkgname=dtkcore-git
-pkgver=2.0.8.1.r1.57ec78b
+pkgver=5.2.2.3.r0.g3241d4d
pkgrel=1
+epoch=1
pkgdesc='DTK core modules'
arch=('x86_64')
url="https://github.com/linuxdeepin/dtkcore"
-license=('GPL3')
-depends=('deepin-qt-dbus-factory' 'dtkcore' 'librsvg' 'qt5-multimedia' 'qt5-svg' 'qt5-x11extras'
- 'startup-notification')
+license=('LGPL3')
+depends=('dconf' 'deepin-desktop-base' 'python' 'gsettings-qt' 'lshw')
+makedepends=('git' 'qt5-tools')
+conflicts=('dtkcore')
+replaces=('dtkcore')
provides=('dtkcore')
-makedepends=('qt5-tools')
-replaces=('deepin-tool-kit')
-conflicts=('deepin-tool-kit<0.3.4' 'dtkcore')
-options=('debug')
-source=("git+https://github.com/linuxdeepin/dtkcore.git")
+group=('deepin-git')
+source=("git://github.com/linuxdeepin/dtkcore.git")
sha512sums=('SKIP')
+pkgver() {
+ cd dtkcore
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd dtkcore
- git checkout 57ec78b
- LDFLAGS=${LDFLAGS/,-z,now/}
- qmake-qt5 PREFIX=/usr
- make -j4
+ qmake-qt5 PREFIX=/usr DTK_VERSION=$pkgver LIB_INSTALL_DIR=/usr/lib
+ make
}
package() {