summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang, DingYuan2020-08-07 19:35:08 +0800
committerZhang, DingYuan2020-08-07 19:35:08 +0800
commit3687f29efd160c3264883d8c1ff057da25dfffe2 (patch)
tree0080653e6b088939a1352080c5665ba750d35a3a
downloadaur-3687f29efd160c3264883d8c1ff057da25dfffe2.tar.gz
update
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee05d01b3d0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = dtkgui-git
+ pkgdesc = Deepin Toolkit, gui module for DDE look and feel
+ pkgver = 5.2.2.1.r1.gb227464
+ pkgrel = 1
+ url = https://github.com/linuxdeepin/dtkgui
+ arch = x86_64
+ groups = deepin-git
+ license = LGPL3
+ makedepends = git
+ makedepends = qt5-tools
+ depends = dtkcore
+ depends = librsvg
+ depends = qt5-x11extras
+ provides = dtkgui
+ conflicts = dtkgui
+ replaces = dtkgui
+ source = git://github.com/linuxdeepin/dtkgui
+ sha512sums = SKIP
+
+pkgname = dtkgui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f18a08d2ea3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: DingYuan Zhang <justforlxz@gmail.com>
+
+pkgname=dtkgui-git
+pkgver=5.2.2.1.r1.gb227464
+pkgrel=1
+pkgdesc='Deepin Toolkit, gui module for DDE look and feel'
+arch=('x86_64')
+url="https://github.com/linuxdeepin/dtkgui"
+license=('LGPL3')
+depends=('dtkcore' 'librsvg' 'qt5-x11extras')
+makedepends=('git' 'qt5-tools')
+conflicts=('dtkgui')
+replaces=('dtkgui')
+provides=('dtkgui')
+groups=('deepin-git')
+source=('git://github.com/linuxdeepin/dtkgui')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd dtkgui
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd dtkgui
+ qmake-qt5 PREFIX=/usr DTK_VERSION=$pkgver LIB_INSTALL_DIR=/usr/lib
+ make
+}
+
+package() {
+ cd dtkgui
+ make INSTALL_ROOT="$pkgdir" install
+}