summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucien2018-08-28 05:15:19 +0200
committerLucien2018-08-28 05:15:19 +0200
commit17376dfd001a220d40b16821707d12cca7132983 (patch)
treea075ca12d093755f74496e02d04306326e05ca2b
downloadaur-17376dfd001a220d40b16821707d12cca7132983.tar.gz
ibr dtn daemon
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD36
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b0f447bc9b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = dtnd
+ pkgdesc = IBR-DTN - A modular and lightweight implementation of the bundle protocol - Daemon
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/ibrdtn/ibrdtn
+ arch = i686
+ arch = x86_64
+ license = Apache License 2.0
+ makedepends = git
+ makedepends = binutils
+ makedepends = gcc
+ makedepends = libtool
+ makedepends = cppunit
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = pkgconf
+ depends = ibrcommon
+ depends = ibrdtn
+ depends = sqlite
+ depends = libcurl-compat
+ depends = libcurl-gnutls
+ depends = libnl
+ depends = libdaemon
+ depends = zlib
+ provides = dtnd
+ source = git://github.com/ibrdtn/ibrdtn.git
+ sha512sums = SKIP
+
+pkgname = dtnd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a89e2c352819
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Lucien LOISEAU (Marlinski) <marlinski@disruptedsystems.org>
+
+pkgname=dtnd
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='IBR-DTN - A modular and lightweight implementation of the bundle protocol - Daemon'
+arch=('i686' 'x86_64')
+url='https://github.com/ibrdtn/ibrdtn'
+license=('Apache License 2.0')
+depends=(ibrcommon ibrdtn sqlite libcurl-compat libcurl-gnutls libnl libdaemon zlib)
+makedepends=(git binutils gcc libtool cppunit automake autoconf pkgconf)
+provides=(dtnd)
+
+source=(git://github.com/ibrdtn/ibrdtn.git)
+sha512sums=('SKIP')
+
+prepare() {
+ cd ibrdtn/
+}
+
+build() {
+ cd ibrdtn/ibrdtn/daemon
+ CXXFLAGS=""
+ [ -f Makefile ] && make clean
+ bash autogen.sh
+ ./configure --prefix=/usr --with-curl --with-lowpan --with-sqlite --with-compression --with-cppunit
+ make -j
+ cd ..
+}
+
+package() {
+ cd ibrdtn/ibrdtn/daemon
+ make DESTDIR="$pkgdir" install
+ mv ${pkgdir}/usr/sbin/dtnd ${pkgdir}/usr/bin/dtnd
+ rmdir ${pkgdir}/usr/sbin
+}