summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBailey Kasin2018-07-30 23:25:55 -0700
committerBailey Kasin2018-07-30 23:25:55 -0700
commit3b301a396dd3f95606b11a410958ec9cf743eb38 (patch)
treef68e8a09c8c18cc89240acc9d58c6bdd5e11e22a
downloadaur-3b301a396dd3f95606b11a410958ec9cf743eb38.tar.gz
DTrace-Utils development tools version 1.0.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e9d1edf2d1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dtrace-utils-devel
+ pkgdesc = DTrace-utils contains the Userspace portion of the DTrace port to Linux
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/oracle/dtrace-utils/
+ arch = x86_64
+ license = GPL
+ makedepends = rpmextract
+ makedepends = rsync
+ source = http://yum.oracle.com/repo/OracleLinux/OL7/UEKR5/x86_64/getPackage/dtrace-utils-devel-1.0.2-1.el7.x86_64.rpm
+ md5sums = abaae48c25afec1cb8e4d1958bcba5b2
+
+pkgname = dtrace-utils-devel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1bb8f79e3cce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Bailey Kasin <bailey@gingertechnology.net>
+pkgname=dtrace-utils-devel
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="DTrace-utils contains the Userspace portion of the DTrace port to Linux"
+arch=('x86_64')
+url="https://github.com/oracle/dtrace-utils/"
+license=('GPL')
+makedepends=(
+ 'rpmextract'
+ 'rsync'
+)
+
+source=("http://yum.oracle.com/repo/OracleLinux/OL7/UEKR5/x86_64/getPackage/dtrace-utils-devel-1.0.2-1.el7.x86_64.rpm")
+md5sums=('abaae48c25afec1cb8e4d1958bcba5b2')
+
+build() {
+ cd "$srcdir"
+ rpmextract.sh ../"dtrace-utils-devel-1.0.2-1.el7.x86_64.rpm"
+}
+
+package() {
+ cd "$srcdir"
+ rsync -ruDq $srcdir/usr $pkgdir
+ cd "$pkgdir"
+ mv usr/lib64 usr/lib
+}