summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranklyn Tackitt2015-06-10 09:05:03 -0700
committerFranklyn Tackitt2015-06-10 09:05:03 -0700
commit0493c3cc34d4392b9de01b92c2058d93bd9b8a8f (patch)
tree00865e4571e024679aad3fa7df86319deb763133
downloadaur-0493c3cc34d4392b9de01b92c2058d93bd9b8a8f.tar.gz
Initial Import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD35
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce82a03f29e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = dtrx
+ pkgdesc = A intelligent archive extraction tool
+ pkgver = 7.1
+ pkgrel = 3
+ url = http://brettcsmith.org/2007/dtrx/
+ arch = any
+ license = GPL3
+ depends = python2
+ optdepends = tar: to extract tar, deb, and gem archives
+ optdepends = unzip: to extract zip archives
+ optdepends = cpio: to extract cpio and rpm archives
+ optdepends = rpm2cpio: to extract rpm archives
+ optdepends = binutils: to extract deb archives
+ optdepends = gzip: deb, gem, gzip, and compress archives
+ optdepends = bzip2: to extract deb and bzip2 archives
+ optdepends = xz: to extract xz archives
+ optdepends = p7zip: to extract 7z archives
+ optdepends = unrar: to extract rar archives
+ optdepends = cabextract: to extract MS Cabinet archives
+ optdepends = unshield: to extract InstallShield archives
+ optdepends = lha: to extract lzh archives
+ source = http://brettcsmith.org/2007/dtrx/dtrx-7.1.tar.gz
+ md5sums = 4be207724b75aea3e9f93374298b2174
+
+pkgname = dtrx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..424c0f1dda6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Kaiting Chen <kaitocracy@gmail.com>
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: rabyte <rabyte*gmail>
+
+pkgname='dtrx'
+pkgver='7.1'
+pkgrel='3'
+pkgdesc='A intelligent archive extraction tool'
+arch=('any')
+url='http://brettcsmith.org/2007/dtrx/'
+license=('GPL3')
+depends=('python2')
+optdepends=(
+ 'tar: to extract tar, deb, and gem archives'
+ 'unzip: to extract zip archives'
+ 'cpio: to extract cpio and rpm archives'
+ 'rpm2cpio: to extract rpm archives'
+ 'binutils: to extract deb archives'
+ 'gzip: deb, gem, gzip, and compress archives'
+ 'bzip2: to extract deb and bzip2 archives'
+ 'xz: to extract xz archives'
+ 'p7zip: to extract 7z archives'
+ 'unrar: to extract rar archives'
+ 'cabextract: to extract MS Cabinet archives'
+ 'unshield: to extract InstallShield archives'
+ 'lha: to extract lzh archives'
+)
+
+md5sums=('4be207724b75aea3e9f93374298b2174')
+source=("$url$pkgname-$pkgver.tar.gz")
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 setup.py install --root="$pkgdir"
+}