summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Dulaney2019-04-11 01:23:19 -0400
committerDaniel Dulaney2019-04-11 01:38:53 -0400
commit2af75838148ea248cd1dfd432e7f61aff209185f (patch)
tree69108217b046c7e8eee2b978564ca3a32c32d48d
downloadaur-2af75838148ea248cd1dfd432e7f61aff209185f.tar.gz
Modified PKGBUILD to pull from GitHub
Based on the existing PKGBUILD in dtrx. The previous one just pulled from the author's website, which has gone down as of 11 Apr 2019. This one will reliably pull from GitHub. Also upated .SRCINFO
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD46
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..202839bcf9e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = dtrx-git
+ pkgdesc = An intelligent archive extraction tool
+ pkgver = 7.1.671ccf7
+ pkgrel = 1
+ url = http://github.com/brettcs/dtrx
+ arch = any
+ license = GPL3
+ depends = python2
+ optdepends = tar: to extract tar, deb, and gem archives
+ optdepends = unzip: to extract zip archives
+ optdepends = cpio: to extract cpio and rpm archives
+ optdepends = rpm-org: to extract rpm archives
+ optdepends = binutils: to extract deb archives
+ optdepends = gzip: deb, gem, gzip, and compress archives
+ optdepends = bzip2: to extract deb and bzip2 archives
+ optdepends = xz: to extract xz archives
+ optdepends = p7zip: to extract 7z archives
+ optdepends = unrar: to extract rar archives
+ optdepends = cabextract: to extract MS Cabinet archives
+ optdepends = unshield: to extract InstallShield archives
+ optdepends = lha: to extract lzh archives
+ provides = dtrx
+ conflicts = dtrx
+ source = git+https://github.com/brettcs/dtrx.git
+ md5sums = SKIP
+
+pkgname = dtrx-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c55d478f7ebc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Mees Valkenburg <`echo Zmx1ZmZ5QGdvZG90LnVrLnRvCg== | base64 -d`>
+# Contributor: Kaiting Chen <kaitocracy@gmail.com>
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: rabyte <rabyte*gmail>
+# Contributor: Daniel Dulaney <dan@dulaney.xyz>
+
+pkgname='dtrx-git'
+pkgver=7.1.671ccf7
+pkgrel=1
+pkgdesc='An intelligent archive extraction tool'
+arch=('any')
+url='http://github.com/brettcs/dtrx'
+license=('GPL3')
+depends=('python2')
+optdepends=(
+ 'tar: to extract tar, deb, and gem archives'
+ 'unzip: to extract zip archives'
+ 'cpio: to extract cpio and rpm archives'
+ 'rpm-org: to extract rpm archives'
+ 'binutils: to extract deb archives'
+ 'gzip: deb, gem, gzip, and compress archives'
+ 'bzip2: to extract deb and bzip2 archives'
+ 'xz: to extract xz archives'
+ 'p7zip: to extract 7z archives'
+ 'unrar: to extract rar archives'
+ 'cabextract: to extract MS Cabinet archives'
+ 'unshield: to extract InstallShield archives'
+ 'lha: to extract lzh archives'
+)
+provides=(dtrx)
+conflicts=(dtrx)
+
+md5sums=('SKIP')
+source=('git+https://github.com/brettcs/dtrx.git')
+
+pkgver() {
+ cd dtrx
+ cat <(python2 setup.py --version | tr "\n" .) \
+ <(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "${srcdir}/dtrx"
+ python2 setup.py install --root="$pkgdir"
+}
+