summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorray454222017-08-01 17:22:44 +0900
committerray454222017-08-01 17:22:44 +0900
commit82b76de3441f9603a968f004e80f07c3f0332ee7 (patch)
tree03480ee31e7adff4c5f9eceaef06f9c2e75a1ba9
downloadaur-82b76de3441f9603a968f004e80f07c3f0332ee7.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ace75e6e8fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Aug 1 08:22:27 UTC 2017
+pkgbase = dub-arm
+ pkgdesc = Developer package manager for D programming language
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://github.com/D-Programming-Language/dub
+ arch = armv7h
+ license = MIT
+ makedepends = ldc
+ provides = dub
+ conflicts = dub
+ source = dub-arm-1.4.0.tar.gz::https://github.com/dlang/dub/archive/v1.4.0.tar.gz
+ sha512sums = 0a21149da3bb09b4c384464eab33adc640938baa9e0bbdac6335583aa6ffe4735846244f2897dfdbd12778ec218b256cf2c58c436c5ffa7244b327af49584ffe
+
+pkgname = dub-arm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4593d80fa90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: ray45422 <ray45422[at]gmail[dot]com>
+
+pkgname=('dub-arm')
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="Developer package manager for D programming language"
+arch=('armv7h')
+url="https://github.com/D-Programming-Language/dub"
+license=('MIT')
+makedepends=('ldc')
+depeonds=('liblphobos' 'curl')
+provides=('dub')
+conflicts=('dub')
+
+source=($pkgname-$pkgver.tar.gz::https://github.com/dlang/dub/archive/v$pkgver.tar.gz)
+sha512sums=('0a21149da3bb09b4c384464eab33adc640938baa9e0bbdac6335583aa6ffe4735846244f2897dfdbd12778ec218b256cf2c58c436c5ffa7244b327af49584ffe')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./build.sh
+}
+
+package() {
+ install -Dm755 "$pkgname-$pkgver/bin/dub" "$pkgdir/usr/bin/dub"
+ install -Dm644 "$pkgname-$pkgver/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$pkgname-$pkgver/scripts/bash-completion/dub.bash" "$pkgdir/usr/share/bash-completion/completions/dub"
+}