summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoruzerus2018-01-08 01:55:06 +0100
committeruzerus2018-01-08 01:55:06 +0100
commit79123118fefad8c0b95f45478d00faac2cc7592e (patch)
treea78fe4e579cd84591ee5b6ce59b20248a6772626
parent08bd6a9721283b90f8926a5a80463bacf591bfb1 (diff)
downloadaur-79123118fefad8c0b95f45478d00faac2cc7592e.tar.gz
its really working...?
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 24 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a563125d7f1e..ab3d6e10843d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
-# Generated by mksrcinfo v8
-# Sun Dec 25 02:34:06 UTC 2016
pkgbase = duck
pkgdesc = Cyberduck CLI
- pkgver = 5.2.2.21483
+ pkgver = 6.3.2.27291
pkgrel = 1
url = https://duck.sh/
arch = x86_64
arch = i686
license = GPL
depends = java-runtime
+ depends = libxtst
+ depends = java-environment-common
+ depends = libglvnd
+ optdepends = gtk2: Graphical interface
+ optdepends = alsa-lib: Audio support
options = !strip
- source_x86_64 = https://repo.cyberduck.io/stable/x86_64/duck-5.2.2.21483.x86_64.rpm
- sha512sums_x86_64 = 888e29739bf573d219b4b5ac1428c7ea32d4c943607a6dfee152b47263df444218a51c98d14919dcabf700478185a5411179ef3df710ca5ffc12c40bd3ebcccc
- source_i686 = https://repo.cyberduck.io/stable/i386/duck-5.2.2.21483.i686.rpm
- sha512sums_i686 = 9558bccb0b45dd55b7e0b129692b691bf9f1de023e034f1e692bbcefba8081fc5f56b13c4a2ecb306fe23bcb693afb6cd52d0fc5ecee32fc7055bced994a9bb9
+ source_x86_64 = https://repo.cyberduck.io/stable/x86_64/duck-6.3.2.27291.x86_64.rpm
+ md5sums_x86_64 = 8266c7932501be5a755163d4b00488f3
+ source_i686 = https://repo.cyberduck.io/stable/i386/duck-6.3.2.27291.i686.rpm
+ md5sums_i686 = 91f4f24b69e26a1e1388d7737a103331
pkgname = duck
diff --git a/PKGBUILD b/PKGBUILD
index 23a3b97246ee..36e5799982ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
-# Maintainer: Matthew Gamble <git@matthewgamble.net>
+# Maintainer uzerus <szymonscholz at gmail dot com>
+# Previous Maintainer: Matthew Gamble
pkgname=duck
-pkgver=5.2.2.21483
+pkgver=6.3.2.27291
pkgrel=1
pkgdesc="Cyberduck CLI"
arch=('x86_64' 'i686')
license=('GPL')
options=(!strip)
url="https://duck.sh/"
-depends=('java-runtime')
-sha512sums_x86_64=('888e29739bf573d219b4b5ac1428c7ea32d4c943607a6dfee152b47263df444218a51c98d14919dcabf700478185a5411179ef3df710ca5ffc12c40bd3ebcccc')
-sha512sums_i686=('9558bccb0b45dd55b7e0b129692b691bf9f1de023e034f1e692bbcefba8081fc5f56b13c4a2ecb306fe23bcb693afb6cd52d0fc5ecee32fc7055bced994a9bb9')
-source_x86_64=("https://repo.cyberduck.io/stable/x86_64/duck-${pkgver}.x86_64.rpm")
-source_i686=("https://repo.cyberduck.io/stable/i386/duck-${pkgver}.i686.rpm")
+depends=('java-runtime' 'libxtst' 'java-environment-common' 'libglvnd')
+optdepends=('gtk2: Graphical interface'
+'alsa-lib: Audio support')
+source_x86_64=("https://repo.cyberduck.io/stable/x86_64/duck-6.3.2.27291.x86_64.rpm")
+source_i686=("https://repo.cyberduck.io/stable/i386/duck-6.3.2.27291.i686.rpm")
package() {
- cp -R opt "${pkgdir}/opt"
- chmod -R go-w "${pkgdir}/opt"
- mkdir -p "${pkgdir}/usr/bin"
- ln -s /opt/duck/duck "${pkgdir}/usr/bin/duck"
+ cp -R opt "${pkgdir}/opt"
+ chmod -R go-w "${pkgdir}/opt/duck"
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s /opt/duck/duck "${pkgdir}/usr/bin/duck"
install -Dm644 "${pkgdir}/opt/duck/duck.desktop" "${pkgdir}/usr/share/applications/duck.desktop"
}
+md5sums_x86_64=('8266c7932501be5a755163d4b00488f3')
+md5sums_i686=('91f4f24b69e26a1e1388d7737a103331')