summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-04-27 05:52:34 +0000
committerxiota2024-04-27 05:52:34 +0000
commit464b5cc38ba2ca213d94f661fa201a5f02596e48 (patch)
tree2e9ffe8a38937b069d4f53c02adfbd50a62a6dbd
parent7bb2252e152d5c238b16b8259fb3ea0020ca6771 (diff)
downloadaur-464b5cc38ba2ca213d94f661fa201a5f02596e48.tar.gz
0.1.6658
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15aaceed55ad..c6da98439b74 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = duckstation
pkgdesc = Playstation emulator
- pkgver = 0.1.6461
+ pkgver = 0.1.6658
pkgrel = 1
url = https://github.com/stenzek/duckstation
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = duckstation
depends = qt6-base
depends = sdl2
depends = shaderc
- source = duckstation::git+https://github.com/stenzek/duckstation.git#commit=359678a1678137f584760991dd4d45574fdbae12
+ source = duckstation::git+https://github.com/stenzek/duckstation.git#commit=4e0c417add264226b3db065c1466791f0591a1b5
sha256sums = SKIP
pkgname = duckstation
diff --git a/PKGBUILD b/PKGBUILD
index ca6202d8052f..0b0bc5941fc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ unset _pkgtype
# basic info
_pkgname="duckstation"
pkgname="$_pkgname${_pkgtype:-}"
-pkgver=0.1.6461
+pkgver=0.1.6658
pkgrel=1
pkgdesc="Playstation emulator"
url="https://github.com/stenzek/duckstation"
@@ -51,7 +51,7 @@ makedepends=(
)
if [ "${_build_git::1}" != "t" ]; then
- _commit=359678a1678137f584760991dd4d45574fdbae12
+ _commit=4e0c417add264226b3db065c1466791f0591a1b5
_pkgsrc="$_pkgname"
source+=("$_pkgsrc"::"git+$url.git#commit=$_commit")
@@ -80,6 +80,13 @@ else
}
fi
+prepare() {
+ # remove shaderc semantic debug
+ sed -e '/vk_khr_shader_non_semantic_info/d' \
+ -e '/SetEmitNonSemanticDebugInfo/d' \
+ -i "$_pkgsrc/src/util/vulkan_pipeline.cpp"
+}
+
build() {
export CC CXX CFLAGS CXXFLAGS LDFLAGS LTOFLAGS
CC="clang"
@@ -130,5 +137,5 @@ END
install -dm755 "$pkgdir/usr/share/pixmaps/"
ln "$pkgdir/opt/$_pkgname/resources/images/duck.png" "$pkgdir/usr/share/pixmaps/duckstation-qt.png"
- chmod -R u=rwX,go=rX "$pkgdir/"
+ chmod -R u+rwX,go+rX,go-w "$pkgdir/"
}