summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-04-20 01:04:29 +0000
committerxiota2024-04-20 01:04:29 +0000
commit7bb2252e152d5c238b16b8259fb3ea0020ca6771 (patch)
tree38eab0fdf111856d63112825e2e926f0a167a954
parent07ef868996cc452f67fb91e7466e75761978f601 (diff)
downloadaur-7bb2252e152d5c238b16b8259fb3ea0020ca6771.tar.gz
fix typo
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ed7047ae477..15aaceed55ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,5 @@
pkgbase = duckstation
+ pkgdesc = Playstation emulator
pkgver = 0.1.6461
pkgrel = 1
url = https://github.com/stenzek/duckstation
diff --git a/PKGBUILD b/PKGBUILD
index 63c0323896d5..ca6202d8052f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ _pkgname="duckstation"
pkgname="$_pkgname${_pkgtype:-}"
pkgver=0.1.6461
pkgrel=1
-_pkgdesc="Playstation emulator"
+pkgdesc="Playstation emulator"
url="https://github.com/stenzek/duckstation"
arch=('x86_64')
license=('GPL-3.0-only')
@@ -50,7 +50,7 @@ makedepends=(
'qt6-tools'
)
-if [ "${_build_git::1}" != "t" ] ; then
+if [ "${_build_git::1}" != "t" ]; then
_commit=359678a1678137f584760991dd4d45574fdbae12
_pkgsrc="$_pkgname"
@@ -87,7 +87,7 @@ build() {
LDFLAGS+=" -fuse-ld=mold"
LTOFLAGS="-flto=thin"
- if [[ "${_build_avx::1}" == "t" ]] ; then
+ if [[ "${_build_avx::1}" == "t" ]]; then
export CFLAGS="$(echo "$CFLAGS" | sed -E 's@(\s*-(march|mtune)=\S+\s*)@ @g;s@\s*-O[0-9]\s*@ @g;s@\s+@ @g') -march=x86-64-v3 -mtune=generic -O3"
export CXXFLAGS="$(echo "$CXXFLAGS" | sed -E 's@(\s*-(march|mtune)=\S+\s*)@ @g;s@\s*-O[0-9]\s*@ @g;s@\s+@ @g') -march=x86-64-v3 -mtune=generic -O3"
fi
@@ -110,12 +110,12 @@ package() {
install -dm755 "$pkgdir/opt/$_pkgname/"
cp --reflink=auto -r build/bin/{resources,translations,duckstation-qt} "$pkgdir/opt/$_pkgname/"
- install -Dm755 /dev/stdin "$pkgdir/usr/bin/duckstation-qt" <<END
+ install -Dm755 /dev/stdin "$pkgdir/usr/bin/duckstation-qt" << END
#!/usr/bin/env bash
exec /opt/$_pkgname/duckstation-qt "\$@"
END
- install -Dm644 /dev/stdin "$pkgdir/usr/share/applications/duckstation-qt.desktop" <<END
+ install -Dm644 /dev/stdin "$pkgdir/usr/share/applications/duckstation-qt.desktop" << END
[Desktop Entry]
Type=Application
Name=DuckStation