summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnonymous Coward2020-04-25 20:23:25 +0200
committerAnonymous Coward2020-04-25 20:23:25 +0200
commit07837c14292b2b60bd11d619c8573e0850d07ddb (patch)
treec546320f569ad2adb1e8e7c625aa9dc27defff22
downloadaur-07837c14292b2b60bd11d619c8573e0850d07ddb.tar.gz
First version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55a3573a2614
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = duckstation-git
+ pkgdesc = A Sony PlayStation (PSX), focusing on playability, speed, and long-term maintainability
+ pkgver = 0.1.r1239.e6bd658
+ pkgrel = 1
+ url = https://github.com/stenzek/duckstation
+ arch = x86_64
+ arch = aarch64
+ license = GPLv3
+ makedepends = git
+ makedepends = cmake
+ depends = gtk2
+ depends = sdl2
+ depends = qt5-base
+ provides = duckstation
+ source = git+https://github.com/stenzek/duckstation.git#branch=master
+ sha256sums = SKIP
+
+pkgname = duckstation-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fb9ab02120e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+
+pkgname=duckstation-git
+pkgver=0.1.r1239.e6bd658
+pkgdesc='A Sony PlayStation (PSX), focusing on playability, speed, and long-term maintainability'
+pkgrel=1
+arch=('x86_64' 'aarch64')
+url="https://github.com/stenzek/duckstation"
+license=('GPLv3')
+makedepends=('git' 'cmake')
+depends=('gtk2' 'sdl2' 'qt5-base')
+optdepends=(
+)
+provides=('duckstation')
+conflicts=()
+
+_branch=master
+source=("git+https://github.com/stenzek/duckstation.git#branch=${_branch}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/duckstation"
+ printf "%s.r%s.%s" "$(git describe --abbrev=0 --tags)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/duckstation"
+
+ cmake -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd "${srcdir}/duckstation"
+
+ install -m 755 -d "${pkgdir}/usr/bin/"
+ install -m 755 -t "${pkgdir}/usr/bin/" src/duckstation-sdl/duckstation-sdl src/duckstation-qt/duckstation-qt
+}