summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRen2023-01-07 00:52:25 +0800
committerRen2023-01-07 00:52:25 +0800
commit74beec6eb24d72d074b8537ebafd52445b0924f8 (patch)
treed869f85c942b36d09561d360faa2cbdf512b52c5
parentc63ac621b887549c5a83ee0f9e1e0def59db0565 (diff)
downloadaur-74beec6eb24d72d074b8537ebafd52445b0924f8.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ba4bd649916..e00b748e5614 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,8 +10,7 @@ pkgbase = duckstation-qt-bin
provides = duckstation
noextract = duckstation-qt-latest.AppImage
options = !strip
- source = duckstation-qt-latest.AppImage::https://github.com/stenzek/duckstation/releases/download/latest/duckstation-qt-x64.AppImage
+ source = duckstation-qt-latest.AppImage::https://github.com/stenzek/duckstation/releases/download/latest/DuckStation-x64.AppImage
sha256sums = SKIP
pkgname = duckstation-qt-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index bc28317e05d8..6bb497bdde5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,13 +12,13 @@ provides=('duckstation-qt' 'duckstation')
options=('!strip')
makedepends=('gendesk')
noextract=("${pkgname%-bin}-${pkgver}.AppImage")
-source=("${pkgname%-bin}-${pkgver}.AppImage::https://github.com/stenzek/duckstation/releases/download/latest/duckstation-qt-x64.AppImage")
+source=("${pkgname%-bin}-${pkgver}.AppImage::https://github.com/stenzek/duckstation/releases/download/latest/DuckStation-x64.AppImage")
sha256sums=('SKIP')
package() {
chmod 755 ./${pkgname%-bin}-${pkgver}.AppImage
./${pkgname%-bin}-${pkgver}.AppImage --appimage-extract
- install -Dm644 squashfs-root/usr/share/icons/hicolor/64x64/apps/${pkgname%-bin}.png "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
+ install -Dm644 squashfs-root/${pkgname%-bin}.png "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
gendesk -f -n --pkgname "${pkgname%-bin}" \
--pkgdesc "$pkgdesc" \
--name "DuckStation-Qt" \