summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgardenapple2024-06-28 19:36:11 +0300
committergardenapple2024-06-28 19:36:11 +0300
commit8d1f807b5ccdaa16f69612f5c4d03660f00a25b6 (patch)
treebcabac0e5b4eecefe6d643eae61181d4abd6c2b1
parent1444416cda51e66c7c84cfd11184f0200508072e (diff)
downloadaur-8d1f807b5ccdaa16f69612f5c4d03660f00a25b6.tar.gz
Revision 6995
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rwxr-xr-xupdate.sh7
3 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1459daf1f8f1..b903d4747421 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = duckstation-qt-bin
pkgdesc = Fast PlayStation 1 emulator for PC and Android
- pkgver = 0.1.r6915
+ pkgver = 0.1.r6995
pkgrel = 1
url = https://github.com/stenzek/duckstation
arch = x86_64
license = GPL-3.0-only
provides = duckstation-qt
provides = duckstation
- noextract = duckstation-qt-0.1.r6915.AppImage
+ noextract = duckstation-qt-0.1.r6995.AppImage
options = !strip
- source = duckstation-qt-0.1.r6915.AppImage::https://github.com/stenzek/duckstation/releases/download/latest/DuckStation-x64.AppImage
- sha256sums = bf91b7b6b00267a52f5f7d13ba736dd6c58e7841881a8dcf7ecd2ca8da32c1eb
+ source = duckstation-qt-0.1.r6995.AppImage::https://github.com/stenzek/duckstation/releases/download/latest/DuckStation-x64.AppImage
+ sha256sums = 825df4d72506997a62c83d379c93e749b638949f5940ac10bfae95dec312ef6e
pkgname = duckstation-qt-bin
diff --git a/PKGBUILD b/PKGBUILD
index 37382d4c97c6..5e3699392554 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=duckstation-qt-bin
_pkgname="${pkgname%-bin}"
_fullname=org.duckstation.DuckStation
-pkgver=0.1.r6915
+pkgver=0.1.r6995
pkgrel=1
pkgdesc="Fast PlayStation 1 emulator for PC and Android"
arch=('x86_64')
@@ -15,7 +15,7 @@ provides=("$_pkgname" 'duckstation')
options=('!strip')
noextract=("${_pkgname}-${pkgver}.AppImage")
source=("${_pkgname}-${pkgver}.AppImage::https://github.com/stenzek/duckstation/releases/download/latest/DuckStation-x64.AppImage")
-sha256sums=('bf91b7b6b00267a52f5f7d13ba736dd6c58e7841881a8dcf7ecd2ca8da32c1eb')
+sha256sums=('825df4d72506997a62c83d379c93e749b638949f5940ac10bfae95dec312ef6e')
package() {
chmod 755 "$srcdir/${_pkgname}-${pkgver}.AppImage"
diff --git a/update.sh b/update.sh
index 2a3ffee26097..e81b9c65a975 100755
--- a/update.sh
+++ b/update.sh
@@ -1,8 +1,13 @@
#!/bin/sh
+
+# Script to help the package maintainer(s).
+# Don't worry about this file if you're just installing the package.
+# Requires xq, wget
+
set -o errexit
-wget --no-clobber 'https://github.com/stenzek/duckstation/releases/download/latest/DuckStation-x64.AppImage'
rm -rf ./squashfs-root
+wget --no-clobber 'https://github.com/stenzek/duckstation/releases/download/latest/DuckStation-x64.AppImage'
chmod u+x ./DuckStation-x64.AppImage
./DuckStation-x64.AppImage --appimage-extract