summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-11-30 03:43:05 +0200
committerDimitris Kiziridis2020-11-30 03:43:05 +0200
commite7f9166972f161d3aa81861aef2798d3c535794d (patch)
tree31fa8a0043719e27a60eef8852ef39eb097367c9
downloadaur-e7f9166972f161d3aa81861aef2798d3c535794d.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ba4bd649916
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = duckstation-qt-bin
+ pkgdesc = Fast PlayStation 1 emulator for PC and Android
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/stenzek/duckstation
+ arch = x86_64
+ license = GPL3
+ makedepends = gendesk
+ provides = duckstation-qt
+ provides = duckstation
+ noextract = duckstation-qt-latest.AppImage
+ options = !strip
+ source = duckstation-qt-latest.AppImage::https://github.com/stenzek/duckstation/releases/download/latest/duckstation-qt-x64.AppImage
+ sha256sums = SKIP
+
+pkgname = duckstation-qt-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73431f55f3f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=duckstation-qt-bin
+pkgver=latest
+pkgrel=1
+pkgdesc="Fast PlayStation 1 emulator for PC and Android"
+arch=('x86_64')
+url='https://github.com/stenzek/duckstation'
+license=('GPL3')
+provides=('duckstation-qt' 'duckstation')
+options=('!strip')
+makedepends=('gendesk')
+noextract=("${pkgname%-bin}-${pkgver}.AppImage")
+source=("${pkgname%-bin}-${pkgver}.AppImage::https://github.com/stenzek/duckstation/releases/download/latest/duckstation-qt-x64.AppImage")
+sha256sums=('SKIP')
+
+package() {
+ chmod 755 ./${pkgname%-bin}-${pkgver}.AppImage
+ ./${pkgname%-bin}-${pkgver}.AppImage --appimage-extract
+ install -Dm644 squashfs-root/usr/share/icons/hicolor/64x64/apps/${pkgname%-bin}.png "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
+ gendesk -f -n --pkgname "${pkgname%-bin}" \
+ --pkgdesc "$pkgdesc" \
+ --name "DuckStation-Qt" \
+ --comment "$pkgdesc" \
+ --exec "${pkgname%-bin}" \
+ --categories 'Utility;Game;Application' \
+ --icon "${pkgname%-bin}"
+ install -Dm644 "${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/opt"
+ cp -avR squashfs-root/ "${pkgdir}/opt/${pkgname%-bin}"
+ echo "#!/usr/bin/env bash
+ cd /opt/${pkgname%-bin}
+ ./AppRun" > ${pkgname%-bin}.sh
+ install -Dm755 ${pkgname%-bin}.sh "${pkgdir}/usr/bin/${pkgname%-bin}"
+ find "${pkgdir}/opt/${pkgname%-bin}" -type d -exec chmod 755 {} +
+}