summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattéo Rossillol2018-03-25 17:16:08 +0200
committerMattéo Rossillol2018-03-25 17:16:08 +0200
commit0f5b2792a9355b6c325b33b4442e0ddeaed9a5f2 (patch)
treedbb78d7711cdeba30977a15de550664d8d5be8fe
parent5d83f0412c42d2c65c8ef65785b7643c078847cd (diff)
downloadaur-0f5b2792a9355b6c325b33b4442e0ddeaed9a5f2.tar.gz
Version 2.6.3-3 :
* Fix issue in 'ducky -h' * Fix issue in desktop file * New icon format
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rwxr-xr-xducky8
-rwxr-xr-xducky-encoder-gui.desktop7
-rw-r--r--ducky-encoder-gui.pngbin3774 -> 7883 bytes
5 files changed, 23 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9d4636438bc..ce149312d365 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by makepkg 5.0.2
-# Wed Feb 7 22:09:07 UTC 2018
+# Sun Mar 25 15:15:33 UTC 2018
pkgbase = ducky-tools
pkgdesc = Tools for USB Rubber Ducky by hak5darren
pkgver = 2.6.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/hak5darren/USB-Rubber-Ducky
arch = i686
arch = x86_64
@@ -26,9 +26,9 @@ pkgbase = ducky-tools
source = ducky-encoder-gui.png
source = ducky
sha256sums = 0e8cc19fa90718953a8c6221c75429bc3970fecb6f000fe0b722568b46e966f4
- sha256sums = eedcd70a5ef10ae7d0ae5b4a31e6912b2c15753d6fc817ab424afd5770cdc2f3
- sha256sums = cbd5dbec562c01bbac94ca9a6b956591babd8c8ab3c2b10f4db6d9aca2250ff9
- sha256sums = bdf984c1aa7951101d7d72109bebf6619b6462b0792f0ed45c3f42e8e6757be0
+ sha256sums = 36aba97ddc5e484b76e575af970459ecb2d82a412f8b2761cae64ae947301f27
+ sha256sums = a722ebe52eaff600706e3d66d12c32324f2d57c402dff28d25e2974ff16dff57
+ sha256sums = 9a3817d59380d1e7f9c5690a1dfc1d740d59c34d8e185d52d081f60e46b726b5
pkgname = ducky-tools
diff --git a/PKGBUILD b/PKGBUILD
index 349f77e8e6cf..d7cabf4adbb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# Maintainer : Matteo Rossillol--Laruelle <mbasiccomputing(at)gmail(dot)com>
+# Maintainer : Beatussum <echo 'YmVhdHVzc3VtQHByb3Rvbm1haWwuY29tCg==' | base64 -d>
_reponame=USB-Rubber-Ducky
pkgname=ducky-tools
pkgver=2.6.3
-pkgrel=2
+pkgrel=3
pkgdesc="Tools for USB Rubber Ducky by hak5darren"
arch=('i686' 'x86_64')
url="https://github.com/hak5darren/$_reponame"
@@ -14,19 +14,19 @@ provides=('duckencoder' 'ducky-encoder-gui' 'ducky-decode' 'ducky-flasher' 'duck
conflicts=('duck-encoder')
options=('!strip')
source=("$pkgname::https://github.com/hak5darren/$_reponame/archive/v$pkgver.tar.gz"
- "ducky-encoder-gui.desktop"
- "ducky-encoder-gui.png"
- "ducky")
+ "ducky-encoder-gui.desktop"
+ "ducky-encoder-gui.png"
+ "ducky")
sha256sums=('0e8cc19fa90718953a8c6221c75429bc3970fecb6f000fe0b722568b46e966f4'
- 'eedcd70a5ef10ae7d0ae5b4a31e6912b2c15753d6fc817ab424afd5770cdc2f3'
- 'cbd5dbec562c01bbac94ca9a6b956591babd8c8ab3c2b10f4db6d9aca2250ff9'
- 'bdf984c1aa7951101d7d72109bebf6619b6462b0792f0ed45c3f42e8e6757be0')
+ '36aba97ddc5e484b76e575af970459ecb2d82a412f8b2761cae64ae947301f27'
+ 'a722ebe52eaff600706e3d66d12c32324f2d57c402dff28d25e2974ff16dff57'
+ '9a3817d59380d1e7f9c5690a1dfc1d740d59c34d8e185d52d081f60e46b726b5')
package(){
cd $srcdir
install -m755 -D "ducky" "$pkgdir/usr/bin/ducky"
- install -m644 -D "ducky-encoder-gui.png" "$pkgdir/usr/share/icons/ducky-encoder-gui.png"
+ install -m644 -D "ducky-encoder-gui.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps/ducky-encoder-gui.png"
install -m755 -D "ducky-encoder-gui.desktop" "$pkgdir/usr/share/applications/ducky-encoder-gui.desktop"
install -d "$pkgdir/opt"
cp -r "$_reponame-$pkgver" "$pkgdir/opt/$_reponame"
diff --git a/ducky b/ducky
index c338e5685c0d..3c48212a3ac8 100755
--- a/ducky
+++ b/ducky
@@ -1,18 +1,20 @@
#!/usr/bin/sh
-readonly VERSION="v2.6.3-2"
+readonly VERSION="v2.6.3-3"
readonly NAME=$(basename "${0}")
usage(){
echo "${NAME} :
encode -i <file> [-o <file>] [-l <keyboardlayout>] : More info with '${NAME} encode -h'
decode -f <file> [-l <keyboardlayout>] : More info with '${NAME} decode -h'
- flash <file> : Flash your ducky with hexadecimal object file (see /opt/USB-Rubber-Ducky/Firmware)
+ flash <file> : Flash your ducky with hexadecimal object file
ducky-flasher : Easily flash your USB Rubber ducky from Hak5
dump <file> : Dump your ducky into hexadecimal object file
-h,--help : Print this message
- -v,--version : Print the program's version"
+ -v,--version : Print the program's version
+
+ Hexadecimal files: /opt/USB-Rubber-Ducky/Firmware"
}
version(){
diff --git a/ducky-encoder-gui.desktop b/ducky-encoder-gui.desktop
index 8fd61590f738..70de73b516cb 100755
--- a/ducky-encoder-gui.desktop
+++ b/ducky-encoder-gui.desktop
@@ -2,10 +2,11 @@
Version=1.0
Name=Ducky Encoder
GenericName=Ducky Encoder (GUI application)
-Comment=Converts the ducky script files into hex files necessary for execution
+Comment=Converts ducky script files to hexadécimal files necessary for execution
Comment[fr]=Convertit les fichiers scripts ducky en fichiers hexadécimaux nécessaires à l'exexution
Exec=java -jar /opt/USB-Rubber-Ducky/Ducky_Encoder_GUI.jar
Icon=ducky-encoder-gui
-Type=Application
Terminal=false
-Categories=Utility;Development;
+Type=Application
+Categories=Utility;
+Keywords=ducky;encoder;gui;
diff --git a/ducky-encoder-gui.png b/ducky-encoder-gui.png
index 9527a790b95f..fadc591655ad 100644
--- a/ducky-encoder-gui.png
+++ b/ducky-encoder-gui.png
Binary files differ