summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorK9002016-10-28 15:14:23 +0300
committerK9002016-10-28 15:21:25 +0300
commit378942a0e64e54b26adcbe6efcacfda699c5064a (patch)
tree18837535f6eef5dead96008d93de3fcac627e4cb
downloadaur-378942a0e64e54b26adcbe6efcacfda699c5064a.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD64
-rw-r--r--duelyst.desktop9
-rw-r--r--duelyst.sh2
-rw-r--r--duelyst_linux.diff21
5 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..583ee81e837a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = duelyst
+ pkgdesc = A collectible card game played on a grid-like board
+ pkgver = 1.75.0
+ pkgrel = 1
+ url = https://duelyst.com/
+ arch = any
+ license = custom
+ makedepends = imagemagick
+ depends = electron
+ options = !strip
+ source = http://downloads.counterplay.co/duelyst/v1.75.0/duelyst-v1.75.0-win32-x64.zip
+ source = LICENSE.html::https://duelyst.com/tos
+ source = duelyst_linux.diff
+ source = duelyst.sh
+ source = duelyst.desktop
+ sha512sums = 007e31a2b228b9ce97c95fd5202f3afe527ee3cb643d0aeea0ffcec896fd5ef5cf0d87ef81a88eda34337373a71d5d58f4f1f9f63def2f7b461a4cbbf1f6e58e
+ sha512sums = 9bb012e75b0702d3321c9677921014932500549b9cbff1cc3f9698987c1b22ba804cb094fe498050e2300681cab4639b6818a05241ce3425704c60bb0a2f57ca
+ sha512sums = a12e18b4ea8d61ea9002cc030dac648632a238ff4d411d1f201ffcb25fbec4ef292db03bbda408cbb397ea8a5fe5c425ae219ddfcaa43f8eae78e4b547283bd1
+ sha512sums = 7999607a9aff7476c6dc2111e170bbcaa9d57c0c659afea27fa736e44904d5500047ecff6b1d3ff2dd2236dbd9c839732cb3da611d23df9861900417906e7261
+ sha512sums = b5ec6a5a4f4bb7b3cb5707758a9061e23014b271a353e2239554b8b1e9448d650e84171381213b6b29ed70b91d30109107aeadc4608ef8a5eac047ada29d7bf3
+
+pkgname = duelyst
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a29d9d11df8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: K900 <me@0upti.me>
+# Patch by notfound4 <https://github.com/notfound4/Duelyst-Launcher>
+pkgname="duelyst"
+pkgver="1.75.0"
+pkgrel=1
+
+pkgdesc="A collectible card game played on a grid-like board"
+url="https://duelyst.com/"
+license=("custom")
+
+arch=("any")
+
+depends=("electron")
+makedepends=("imagemagick")
+
+# we don't have any ELF files
+options=("!strip")
+
+source=(
+ "http://downloads.counterplay.co/duelyst/v${pkgver}/duelyst-v${pkgver}-win32-x64.zip"
+ "LICENSE.html::https://duelyst.com/tos"
+ "duelyst_linux.diff"
+ "duelyst.sh"
+ "duelyst.desktop"
+)
+
+sha512sums=(
+ "007e31a2b228b9ce97c95fd5202f3afe527ee3cb643d0aeea0ffcec896fd5ef5cf0d87ef81a88eda34337373a71d5d58f4f1f9f63def2f7b461a4cbbf1f6e58e"
+ "9bb012e75b0702d3321c9677921014932500549b9cbff1cc3f9698987c1b22ba804cb094fe498050e2300681cab4639b6818a05241ce3425704c60bb0a2f57ca"
+ "a12e18b4ea8d61ea9002cc030dac648632a238ff4d411d1f201ffcb25fbec4ef292db03bbda408cbb397ea8a5fe5c425ae219ddfcaa43f8eae78e4b547283bd1"
+ "7999607a9aff7476c6dc2111e170bbcaa9d57c0c659afea27fa736e44904d5500047ecff6b1d3ff2dd2236dbd9c839732cb3da611d23df9861900417906e7261"
+ "b5ec6a5a4f4bb7b3cb5707758a9061e23014b271a353e2239554b8b1e9448d650e84171381213b6b29ed70b91d30109107aeadc4608ef8a5eac047ada29d7bf3"
+)
+
+prepare() {
+ cd "${srcdir}/resources/app"
+ patch -i "${srcdir}/duelyst_linux.diff" "desktop.js"
+}
+
+package() {
+ mkdir -p "${pkgdir}/opt/duelyst"
+ cd "${srcdir}/resources/app"
+
+ # clear out some libs
+ find -name "*.dylib" -delete
+ find -name "*.dll" -delete
+
+ # remove Steamworks libs
+ rm steam/greenworks*
+
+ install -Dm755 "${srcdir}/duelyst.sh" "${pkgdir}/usr/bin/duelyst"
+
+ for size in 16 24 32 48 64 128 256 512 1024; do
+ icon_dir="${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps"
+ mkdir -p "${icon_dir}"
+ convert "icon.png" -resize "${size}x${size}" "${icon_dir}/duelyst.png"
+ done
+
+ install -Dm644 "${srcdir}/duelyst.desktop" "${pkgdir}/usr/share/applications/duelyst.desktop"
+
+ install -Dm644 "${srcdir}/LICENSE.html" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE.html"
+
+ cp -rv --no-preserve=ownership -- * "${pkgdir}/opt/duelyst"
+}
diff --git a/duelyst.desktop b/duelyst.desktop
new file mode 100644
index 000000000000..7edf161d1093
--- /dev/null
+++ b/duelyst.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Duelyst
+Comment=A collectible card game played on a grid-like board
+Generic Name=Collectible Card Game
+Exec=duelyst
+Icon=duelyst
+Type=Application
+StartupNotify=true
+Categories=Game; \ No newline at end of file
diff --git a/duelyst.sh b/duelyst.sh
new file mode 100644
index 000000000000..b347d566b29e
--- /dev/null
+++ b/duelyst.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+electron --app=/opt/duelyst $@
diff --git a/duelyst_linux.diff b/duelyst_linux.diff
new file mode 100644
index 000000000000..28d32d1d289b
--- /dev/null
+++ b/duelyst_linux.diff
@@ -0,0 +1,21 @@
+58a59,60
+> argv.token = '32432543254'
+>
+62,74d63
+< if (pkgJson.name === 'duelyst' && argv.token === undefined) {
+< dialog.showMessageBox({
+< type: 'error',
+< title: 'ERROR',
+< message: 'Please use the launcher to start Duelyst',
+< detail: 'You cannot start the Duelyst executable directly.',
+< buttons: []
+< }, app.quit)
+< return
+< }
+<
+< // if using steam, attempt to initialize steamworks api
+< // otherwise display dialog erroring out
+94c83
+< if (process.platform === 'win32') setupWin32Shortcuts()
+---
+> if (process.platform === 'win32' || process.platform === 'linux') setupWin32Shortcuts()