summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Coenen2019-09-02 12:40:30 +0200
committerManuel Coenen2019-09-02 12:40:30 +0200
commit347a776c95a6c22af1643ce473c6ca900c7050fb (patch)
treea48a73eb3f2d50e5d41b382dc548d7eb2535d883
downloadaur-347a776c95a6c22af1643ce473c6ca900c7050fb.tar.gz
Initial version of duetruntime-bin package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..760f5aa6270c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = duetruntime-bin
+ pkgdesc = .NET Core runtime libraries for the Duet software framework
+ pkgver = 1.0.3.1
+ pkgrel = 1
+ url = https://github.com/chrishamm/DuetSoftwareFramework
+ arch = armv7h
+ license = GPL3
+ depends = curl
+ depends = gettext
+ depends = libunwind
+ provides = duetruntime
+ conflicts = duetruntime
+ options = !strip
+ options = staticlibs
+ source = https://pkg.duet3d.com/dists/stable/armv7/binary-armhf/duetruntime_1.0.3.1.deb
+ sha256sums = 5254d60f81d50165f6a4e7ff5182efa644dbd358979837d7886f6d98c3a7dce7
+
+pkgname = duetruntime-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c43b211b0d22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Manuel Coenen <manuel.coenen@gmail.com>
+pkgname=duetruntime-bin
+pkgver=1.0.3.1
+pkgrel=1
+pkgdesc=".NET Core runtime libraries for the Duet software framework"
+arch=('armv7h')
+url="https://github.com/chrishamm/DuetSoftwareFramework"
+license=('GPL3')
+provides=('duetruntime')
+conflicts=('duetruntime')
+depends=('curl' 'gettext' 'libunwind')
+options=(!strip staticlibs)
+source=("https://pkg.duet3d.com/dists/stable/armv7/binary-armhf/duetruntime_${pkgver}.deb")
+sha256sums=('5254d60f81d50165f6a4e7ff5182efa644dbd358979837d7886f6d98c3a7dce7')
+
+prepare() {
+ tar -xf data.tar.xz
+}
+
+package() {
+ install -dm 755 "${pkgdir}"/opt/dsf/bin
+ install -m 644 "${srcdir}/opt/dsf/bin/"* "${pkgdir}/opt/dsf/bin"
+}