summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Coenen2019-09-02 12:40:31 +0200
committerManuel Coenen2019-09-02 12:40:31 +0200
commitd2d7a0aa19d326b9a13b257c78cde73a7342e30b (patch)
treeafcd2ace8230c9aee878c42af930df9fef1ee781
downloadaur-d2d7a0aa19d326b9a13b257c78cde73a7342e30b.tar.gz
Initial version of duetsd-bin package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58293898d4bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = duetsd-bin
+ pkgdesc = Virtual SD card directory for the Duet software framework
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/chrishamm/DuetSoftwareFramework
+ arch = any
+ license = GPL3
+ optdepends = duetwebcontrol
+ provides = duetsd
+ conflicts = duetsd
+ source = https://pkg.duet3d.com/dists/stable/armv7/binary-armhf/duetsd_1.0.1.deb
+ sha256sums = 0f134994cf55f1b8e8cf4efe9e04876b6c6cb1d09fc3546acdeac0ca50a47242
+
+pkgname = duetsd-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..028096fb8c17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Manuel Coenen <manuel.coenen@gmail.com>
+pkgname=duetsd-bin
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Virtual SD card directory for the Duet software framework"
+arch=('any')
+url="https://github.com/chrishamm/DuetSoftwareFramework"
+license=('GPL3')
+provides=('duetsd')
+conflicts=('duetsd')
+optdepends=('duetwebcontrol')
+source=("https://pkg.duet3d.com/dists/stable/armv7/binary-armhf/duetsd_${pkgver}.deb")
+sha256sums=('0f134994cf55f1b8e8cf4efe9e04876b6c6cb1d09fc3546acdeac0ca50a47242')
+
+prepare() {
+ tar -xf data.tar.xz
+}
+
+package() {
+ # Virtual SD Card
+ install -dm 755 "${pkgdir}"/opt/dsf/sd/{sys,macros,gcodes,filaments}
+ install -m 644 "${srcdir}"/opt/dsf/sd/sys/* "${pkgdir}"/opt/dsf/sd/sys/
+ ln -s "/opt/dsf/dwc2" "${pkgdir}/opt/dsf/sd/www"
+}