summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElliot Hatch2023-12-27 23:59:55 -0700
committerElliot Hatch2023-12-27 23:59:55 -0700
commit4a8f073d3eb54378e670655ca78160cb8dd2c7f9 (patch)
tree7ae047eb62842a8d949d8e71d1dd57e13307ada8
parentc7a9d8576b0c43679332379f823f262c2eb73b60 (diff)
downloadaur-dug-git.tar.gz
Update to work with upstream dotnet 6, fix install bin path
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD6
-rwxr-xr-xbuild.sh4
3 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 093f502b10f8..c81124740c93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = dug-git
pkgdesc = A powerful global DNS progagation checker that can output in a variety of formats.
- pkgver = r218.7502669
+ pkgver = r284.55f6ecb
pkgrel = 1
url = https://dug.unfrl.com/
arch = x86_64
license = custom:ANTI-CAPITALIST SOFTWARE LICENSE v1.4
makedepends = git
- makedepends = dotnet-runtime>=5.0.0
- makedepends = dotnet-sdk>=5.0.0,
- makedepends = dotnet-host>=5.0.0
+ makedepends = dotnet-runtime>=6.0.0
+ makedepends = dotnet-sdk>=6.0.0,
+ makedepends = dotnet-host>=6.0.0
provides = dug
options = !strip
source = dug-git::git+https://github.com/unfrl/dug.git
md5sums = SKIP
pkgname = dug-git
-
diff --git a/PKGBUILD b/PKGBUILD
index af1ded13e8f7..81f11535ebde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Elliot Hatch <elliot.hatch@gmail.com>
pkgname=dug-git
-pkgver=r218.7502669
+pkgver=r284.55f6ecb
pkgrel=1
pkgdesc="A powerful global DNS progagation checker that can output in a variety of formats."
arch=(x86_64)
url="https://dug.unfrl.com/"
license=('custom:ANTI-CAPITALIST SOFTWARE LICENSE v1.4')
depends=()
-makedepends=(git 'dotnet-runtime>=5.0.0' 'dotnet-sdk>=5.0.0', 'dotnet-host>=5.0.0')
+makedepends=(git 'dotnet-runtime>=6.0.0' 'dotnet-sdk>=6.0.0', 'dotnet-host>=6.0.0')
provides=(dug)
options=(!strip)
source=($pkgname::git+https://github.com/unfrl/dug.git)
@@ -36,5 +36,5 @@ package() {
install -D -m644 "./cli/LICENSE" -t "$pkgdir/usr/share/licenses/dug"
- install -D -m755 "./cli/bin/Release/net5.0/linux-x64/publish/dug" -t "$pkgdir/usr/bin"
+ install -D -m755 "./cli/bin/Release/net6.0/linux-x64/publish/dug" -t "$pkgdir/usr/bin"
}
diff --git a/build.sh b/build.sh
new file mode 100755
index 000000000000..df2eb18d2ca2
--- /dev/null
+++ b/build.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+namcap PKGBUILD
+makepkg -f
+makepkg --printsrcinfo > .SRCINFO