summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-10-26 21:06:18 +0100
committerAlexander F Rødseth2015-10-26 21:06:18 +0100
commitf29fceddf0c5d3f2f585f121b6f4cd1feac4b70c (patch)
tree7408f50d9ac3293dfd90c6037beb5842c7947441
downloadaur-f29fceddf0c5d3f2f585f121b6f4cd1feac4b70c.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a692cbe92458
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Oct 26 20:05:50 UTC 2015
+pkgbase = dui
+ pkgdesc = Cross-platform tool for removing modified subversion files
+ pkgver = 1
+ pkgrel = 1
+ url = https://gist.github.com/xyproto/d3b49582bc2b16aee5b0
+ arch = x86_64
+ arch = i686
+ license = custom
+ optdepends = subversion: For dealing with svn repos
+ source = https://gist.githubusercontent.com/xyproto/d3b49582bc2b16aee5b0/raw/a70e38ca03b24c0e5e215a51f6b72a7921492f35/dui.c
+ md5sums = 7af33879b0f6fa73ff099fa0ddec61cb
+
+pkgname = dui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82158d94bf6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+
+pkgname=dui
+pkgver=1
+pkgrel=1
+pkgdesc='Cross-platform tool for removing modified subversion files'
+arch=('x86_64' 'i686')
+url='https://gist.github.com/xyproto/d3b49582bc2b16aee5b0'
+license=('custom')
+optdepends=('subversion: For dealing with svn repos')
+source=('https://gist.githubusercontent.com/xyproto/d3b49582bc2b16aee5b0/raw/a70e38ca03b24c0e5e215a51f6b72a7921492f35/dui.c')
+md5sums=('7af33879b0f6fa73ff099fa0ddec61cb')
+
+build() {
+ gcc -O dui.c -o dui
+}
+
+package() {
+ install -Dm755 dui "$pkgdir/usr/bin/dui"
+}
+
+# vim:set ts=2 sw=2 et: