summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPherelo HD2021-01-13 14:15:49 +0100
committerPherelo HD2021-01-13 14:15:49 +0100
commit3d15f3ead1a129eca0aec1d4a82c2491693ff2ce (patch)
tree54e11d380d28c9309b2cf9e634ac1ae455f4fb68
downloadaur-3d15f3ead1a129eca0aec1d4a82c2491693ff2ce.tar.gz
Initial Commit.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD40
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e552e09e024
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = duino-coin
+ pkgdesc = is a cryptocurrency that can also be mined with AVR boards.
+ pkgver = 1.9.1
+ pkgrel = 1
+ url = https://github.com/revoxhere/duino-coin
+ arch = x86_64
+ license = MIT
+ optdepends = python: needed for actually running the PC_Miner
+ optdepends = python-pip: needed for dependencies in the Miner
+ source = duino-coin-1.9.1.tar.gz::https://github.com/revoxhere/duino-coin/archive/1.9.1.tar.gz
+ sha256sums = 1b022473abafa2faa70a93a38d06c66e8fe19baab880e4e61f2865d5b3fc75c6
+
+pkgname = duino-coin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb0aa94e73c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+#Lead Contributor: revoxhere <https://github.com/revoxhere/duino-coin>
+#Maintainer: Pherelo HD <pherelohd@protonmail.com>
+ENABLE_FLATPAK=0
+ENABLE_SNAPD=0
+
+pkgname=duino-coin
+pkgver=1.9.1
+pkgrel=1
+
+pkgdesc="is a cryptocurrency that can also be mined with AVR boards."
+arch=('x86_64')
+url="https://github.com/revoxhere/duino-coin"
+license=('MIT')
+optdepends=('python: needed for actually running the PC_Miner'
+ 'python-pip: needed for dependencies in the Miner')
+
+sha256sums=('1b022473abafa2faa70a93a38d06c66e8fe19baab880e4e61f2865d5b3fc75c6')
+
+
+
+source=("$pkgname-$pkgver.tar.gz::https://github.com/revoxhere/duino-coin/archive/1.9.1.tar.gz")
+
+
+
+prepare(){
+
+ cd "$pkgname-$pkgver"
+
+}
+
+build(){
+
+
+mkdir -p "~/duco"
+}
+
+package(){
+mkdir -p "~/duco"
+cp "$pkgname-$pkgver.tar.gz" "$HOME/"
+}