summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrevel2021-06-12 10:10:20 +0200
committerrevel2021-06-12 10:10:20 +0200
commit9b9c156f712574173e961bb5d072dfabb719f014 (patch)
treea32d4a8c79d6c8b6d1fe994cdc7399eb742150e3
parent47775e9a9e7c9aee5815b410c779312e48616010 (diff)
downloadaur-9b9c156f712574173e961bb5d072dfabb719f014.tar.gz
- updated to version 2.5.21
- updated project url to github
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 22 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3537be47578..a199a089c607 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = duma
- pkgdesc = Multi-platform memory debugging library (Detect Unintended Memory Access)
- pkgver = 2.5.15
- pkgrel = 3
- url = http://duma.sourceforge.net/
+ pkgdesc = Detect Unintended Memory Access (D.U.M.A.) - A Red-Zone memory allocator
+ pkgver = 2.5.21
+ pkgrel = 1
+ url = https://github.com/johnsonjh/duma
arch = i686
arch = x86_64
license = GPL
depends = bash
depends = gcc-libs
- source = http://sourceforge.net/projects/duma/files/duma/2.5.15/duma_2_5_15.tar.gz
- md5sums = fe630c69cbaa39caf225a3d9ed2fda1f
- sha256sums = baaf794854e3093ad1bddadbfb8ad4b220a7117d70359ee216bd59e353734e17
+ source = https://github.com/johnsonjh/duma/archive/refs/tags/VERSION_2_5_21.tar.gz
+ sha256sums = 470aa72e7018f0beadb5fbe3c932a62ba1b0594c29158a744c614bfa42133e59
pkgname = duma
diff --git a/PKGBUILD b/PKGBUILD
index 2a27ff397512..8ced2893a42e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,34 @@
# Contributor: tmm1 <archΘtmm1·net>
pkgname=duma
-pkgver=2.5.15
-pkgrel=3
-pkgdesc='Multi-platform memory debugging library (Detect Unintended Memory Access)'
+pkgver=2.5.21
+pkgrel=1
+pkgdesc='Detect Unintended Memory Access (D.U.M.A.) - A Red-Zone memory allocator'
arch=('i686' 'x86_64')
-url='http://duma.sourceforge.net/'
+url='https://github.com/johnsonjh/duma'
license=('GPL')
depends=('bash' 'gcc-libs')
_pkgver="${pkgver//./_}"
-source=("http://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/${pkgname}_${_pkgver}.tar.gz")
-md5sums=('fe630c69cbaa39caf225a3d9ed2fda1f')
-sha256sums=('baaf794854e3093ad1bddadbfb8ad4b220a7117d70359ee216bd59e353734e17')
+source=("https://github.com/johnsonjh/duma/archive/refs/tags/VERSION_${_pkgver}.tar.gz")
+sha256sums=('470aa72e7018f0beadb5fbe3c932a62ba1b0594c29158a744c614bfa42133e59')
prepare() {
- cd "${pkgname}_${_pkgver}"
- sed -i 's/CPPFLAGS=/\0-std=gnu++98 /g' GNUmakefile
+ cd "${pkgname}-VERSION_${_pkgver}"
+# sed -i 's/CPPFLAGS=/\0-std=gnu++98 /g' GNUmakefile
}
build() {
- cd "${pkgname}_${_pkgver}"
+ cd "${pkgname}-VERSION_${_pkgver}"
make
}
+check() {
+ cd "${pkgname}-VERSION_${_pkgver}"
+# make check
+}
+
package() {
- cd "${pkgname}_${_pkgver}"
+ cd "${pkgname}-VERSION_${_pkgver}"
make prefix="$pkgdir/usr/" install
- install -m644 duma_hlp.h "$pkgdir/usr/include/"
+# install -m644 duma_hlp.h "$pkgdir/usr/include/"
}