summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortocic2022-12-03 12:20:10 +0300
committertocic2022-12-03 12:20:10 +0300
commitcfef4ed38b734d6f403653db825944348b71eff3 (patch)
tree7b21a9338375d34a86d51a6556722b4650f1d1a9
downloadaur-cfef4ed38b734d6f403653db825944348b71eff3.tar.gz
Add build files
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD40
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32310dcce853
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = duma-git
+ pkgdesc = Detect Unintended Memory Access (D.U.M.A.) - A Red-Zone memory allocator
+ pkgver = 2.5.24b1.r25.g2aab759
+ pkgrel = 1
+ url = https://github.com/johnsonjh/duma
+ arch = x86_64
+ license = GPL2
+ license = LGPL2.1
+ makedepends = cmake
+ makedepends = git
+ depends = bash
+ provides = duma
+ conflicts = duma
+ source = duma-git::git+https://github.com/johnsonjh/duma#branch=master
+ b2sums = SKIP
+
+pkgname = duma-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2f5661e0609c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/**
+!/**/
+
+!/.gitignore
+!/.SRCINFO
+!/PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..311010f6a08a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: tocic <tocic at protonmail dot ch>
+
+pkgname=duma-git
+pkgver=2.5.24b1.r25.g2aab759
+pkgrel=1
+pkgdesc="Detect Unintended Memory Access (D.U.M.A.) -
+ A Red-Zone memory allocator"
+arch=("x86_64")
+url="https://github.com/johnsonjh/duma"
+license=("GPL2" "LGPL2.1")
+depends=("bash")
+makedepends=("cmake" "git")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname}::git+https://github.com/johnsonjh/duma#branch=master")
+b2sums=("SKIP")
+
+pkgver() {
+ printf "%s" \
+ $(git -C "${pkgname}" describe --long --tags \
+ | sed "s/^VERSION_//;s/_BETA_/b/;s/\([^-]*-g\)/r\1/;s/-/./g;s/_/./g")
+}
+
+build() {
+ # Intentionally disable the makepkg.conf options
+ # since the library requires a debug build
+ cmake -B "build/" -S "${pkgname}" \
+ -D BUILD_TESTS:BOOL="OFF" \
+ -D BUILD_EXAMPLES:BOOL="OFF" \
+ -D CMAKE_C_FLAGS:STRING="-fmacro-prefix-map=${srcdir}/=" \
+ -D CMAKE_CXX_FLAGS:STRING="-fmacro-prefix-map=${srcdir}/=" \
+ -D CMAKE_INSTALL_PREFIX:PATH="/usr/" \
+ -Wno-dev
+
+ cmake --build "build/"
+}
+
+package() {
+ DESTDIR="${pkgdir}" cmake --install "build/"
+}