summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven-Hendrik Haase2018-06-12 13:37:00 +0200
committerSven-Hendrik Haase2018-06-12 13:37:00 +0200
commit719b59b438d15b49717de5413713082a6aac8e0c (patch)
tree60583868395707d28ab8c4dc02c2a89342d87050
downloadaur-719b59b438d15b49717de5413713082a6aac8e0c.tar.gz
Push dummyhttp
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2419147831f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = dummyhttp
+ pkgdesc = Super simple HTTP server that replies a fixed body with a fixed response code
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/svenstaro/dummyhttp
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ source = https://github.com/svenstaro/dummyhttp/archive/0.1.1.tar.gz
+ sha512sums = 796d2c46d8b7f56baa142013a4208f240976db7826046c4ce536b1873ed66e60eb5299fd209ee446924b79463ade1fa3cf9d362c5634d117fc2ab3cf3f70d09f
+
+pkgname = dummyhttp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fdd671aa1a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Sven-Hendrik Haase <svenstaro@gmail.com>
+
+pkgname=dummyhttp
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Super simple HTTP server that replies a fixed body with a fixed response code
+"
+arch=('x86_64')
+url="https://github.com/svenstaro/dummyhttp"
+license=(MIT)
+makedepends=(cargo)
+source=(https://github.com/svenstaro/dummyhttp/archive/${pkgver}.tar.gz)
+sha512sums=('796d2c46d8b7f56baa142013a4208f240976db7826046c4ce536b1873ed66e60eb5299fd209ee446924b79463ade1fa3cf9d362c5634d117fc2ab3cf3f70d09f')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ cargo build --release
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm755 target/release/dummyhttp "$pkgdir"/usr/bin/dummyhttp
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: