summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMisaka135142023-01-11 13:55:54 +0800
committerMisaka135142023-01-11 13:55:54 +0800
commite452393cb4e04809abf37091c0ee46182045e3d3 (patch)
treefed26bf93bf2791daf64216e69b977e9669f2fce
parent4f3ff70abf4ab8000716066804ce0de654c83c6c (diff)
downloadaur-e452393cb4e04809abf37091c0ee46182045e3d3.tar.gz
upgpkg: dump1090-git r386.bff92c4-2
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD55
-rw-r--r--dump1090.patch45
3 files changed, 86 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e58925c7d492..06313745f924 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
-# Generated by mksrcinfo v8
-# Wed Dec 16 02:43:10 UTC 2020
pkgbase = dump1090-git
- pkgdesc = Dump1090 is a simple Mode S decoder for RTLSDR devices. MalcolmRobb fork. Git version.
- pkgver = 0.r386.bff92c4
- pkgrel = 1
+ pkgdesc = A simple Mode S decoder for RTLSDR devices. MalcolmRobb fork.
+ pkgver = r386.bff92c4
+ pkgrel = 2
url = https://github.com/MalcolmRobb/dump1090
- arch = i686
arch = x86_64
+ arch = aarch64
license = BSD
makedepends = git
depends = rtl-sdr
- provides = dump1090
- source = git://github.com/MalcolmRobb/dump1090.git
- md5sums = SKIP
+ provides = _pkgname
+ conflicts = _pkgname
+ source = dump1090::git+https://github.com/MalcolmRobb/dump1090.git
+ source = dump1090.patch
+ sha256sums = SKIP
+ sha256sums = c5d6c2de9326686f88c0beea8f2ea3539187bc2b6f654fcc921517d9ccbce514
pkgname = dump1090-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 009b47cb94cc..62d5d03324c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,50 @@
-# Maintainer: qs9rx < that nick at enjoys dot it>
+# Maintainer: Misaka13514 <Misaka13514 at gmail dot com>
+# Contributor: qs9rx <that nick at enjoys dot it>
# Contributor: David Manouchehri <d@32t.ca>
pkgname=dump1090-git
-_gitname=dump1090
-pkgver=0.r386.bff92c4
-pkgrel=1
-pkgdesc="Dump1090 is a simple Mode S decoder for RTLSDR devices. MalcolmRobb fork. Git version."
-arch=('i686' 'x86_64')
+_pkgname=${pkgname%-git}
+pkgver=r386.bff92c4
+pkgrel=2
+pkgdesc="A simple Mode S decoder for RTLSDR devices. MalcolmRobb fork."
+arch=('x86_64' 'aarch64')
url="https://github.com/MalcolmRobb/dump1090"
license=('BSD')
depends=('rtl-sdr')
-provides=('dump1090')
+provides=(_pkgname)
+conflicts=(_pkgname)
makedepends=('git')
-source=('git://github.com/MalcolmRobb/dump1090.git')
-md5sums=('SKIP')
-
+source=(
+ "$_pkgname::git+$url.git"
+ "$_pkgname.patch")
+sha256sums=(
+ 'SKIP'
+ 'c5d6c2de9326686f88c0beea8f2ea3539187bc2b6f654fcc921517d9ccbce514')
+
pkgver() {
- cd "$srcdir/$_gitname"
- printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/$_pkgname"
# gcc10 tweaks
- sed -i 's/^struct stDF {/extern &/' dump1090.h
- sed -i 's/^struct {.*Internal state$/static &/' dump1090.h
- sed -i 's/^CFLAGS=.*$/& -fPIC/' Makefile
+ patch -p1 -i "$srcdir/$_pkgname.patch"
+
+ sed -i 's#./public_html#/usr/share/dump1090/public_html#g' dump1090.h
}
build() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/$_pkgname"
make clean
- make PREFIX=/usr/
+ make
}
-
-package() {
- install -Dm755 "$srcdir/$_gitname/dump1090" "$pkgdir/usr/bin/dump1090"
- install -Dm755 "$srcdir/$_gitname/view1090" "$pkgdir/usr/bin/view1090"
- install -d "$pkgdir/usr/share"
- cp -r "$srcdir/$_gitname/public_html/" "$pkgdir/usr/share/$_gitname/"
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 "dump1090" "$pkgdir/usr/bin/dump1090"
+ install -Dm755 "view1090" "$pkgdir/usr/bin/view1090"
+ install -dm755 "$pkgdir/usr/share/$_pkgname"
+ cp -dpr --no-preserve=ownership public_html testfiles tools "$pkgdir/usr/share/$_pkgname/"
+ install -Dm 644 -t "$pkgdir/usr/share/doc/$pkgname/" README.md TODO
}
diff --git a/dump1090.patch b/dump1090.patch
new file mode 100644
index 000000000000..efbc565640e4
--- /dev/null
+++ b/dump1090.patch
@@ -0,0 +1,45 @@
+diff --git a/dump1090.c b/dump1090.c
+index 60882fc..1482224 100644
+--- a/dump1090.c
++++ b/dump1090.c
+@@ -29,6 +29,9 @@
+ //
+ #include "coaa.h"
+ #include "dump1090.h"
++
++struct modes Modes;
++
+ //
+ // ============================= Utility functions ==========================
+ //
+diff --git a/dump1090.h b/dump1090.h
+index 9ad4de0..283e760 100644
+--- a/dump1090.h
++++ b/dump1090.h
+@@ -235,10 +235,10 @@ struct stDF {
+ uint64_t llTimestamp; // Timestamp at which the this packet was received
+ uint32_t addr; // Timestamp at which the this packet was received
+ unsigned char msg[MODES_LONG_MSG_BYTES]; // the binary
+-} tDF;
++};
+
+ // Program global state
+-struct { // Internal state
++extern struct modes { // Internal state
+ pthread_t reader_thread;
+
+ pthread_mutex_t data_mutex; // Mutex to synchronize buffer access
+diff --git a/view1090.c b/view1090.c
+index 0b9b8b9..cc072fc 100644
+--- a/view1090.c
++++ b/view1090.c
+@@ -29,6 +29,9 @@
+ //
+ #include "coaa.h"
+ #include "view1090.h"
++
++struct modes Modes;
++
+ //
+ // ============================= Utility functions ==========================
+ //