summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquininer2020-05-15 13:14:34 +0800
committerquininer2020-05-15 13:14:34 +0800
commitad08211c9c9530219a5cb8f53cad15985ce34cf1 (patch)
tree62e3a5346900e55d07e1e0320b3fbf2172c94519
downloadaur-ad08211c9c9530219a5cb8f53cad15985ce34cf1.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebefa423d655
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = dump_syms-git
+ pkgdesc = Rewrite of breakpad dump_syms tools in Rust
+ pkgver = 0.0.5.102.ge28a20b
+ pkgrel = 1
+ url = https://github.com/mozilla/dump_syms
+ arch = x86_64
+ arch = i686
+ license = Apache
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ makedepends = git
+ provides = dump_syms
+ conflicts = dump_syms
+ source = dump_syms::git+https://github.com/mozilla/dump_syms.git
+ sha256sums = SKIP
+
+pkgname = dump_syms-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44c7d0781a5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname='dump_syms-git'
+_pkgname="dump_syms"
+pkgver=0.0.5.102.ge28a20b
+pkgrel=1
+arch=('x86_64' 'i686')
+url="https://github.com/mozilla/dump_syms"
+pkgdesc=" Rewrite of breakpad dump_syms tools in Rust"
+license=('Apache' 'MIT')
+depends=()
+makedepends=('rust' 'cargo' 'git')
+provides=('dump_syms')
+conflicts=('dump_syms')
+source=("$_pkgname::git+https://github.com/mozilla/dump_syms.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2|cut -d\- -f1).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build(){
+ cd "$_pkgname"
+ env CARGO_INCREMENTAL=0 cargo build --release --locked
+}
+
+package() {
+ cd $_pkgname
+
+ install -D -m755 "target/release/dump_syms" "$pkgdir/usr/bin/dump_syms"
+}