summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Gondža2020-03-28 18:12:19 +0100
committerOliver Gondža2020-03-28 18:13:12 +0100
commitf418fcbdb425442f616309db8684bb098132415d (patch)
tree9acee8bb0feeccf7ae23764364d91a78c31fea92
downloadaur-f418fcbdb425442f616309db8684bb098132415d.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD33
-rwxr-xr-xbuild.sh11
-rw-r--r--dumpling3
5 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa1cb5beb3c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dumpling
+ pkgdesc = Automation friendly java threaddump analyzer
+ pkgver = 2.4
+ pkgrel = 1
+ epoch = 0
+ url = https://olivergondza.github.io/dumpling/
+ arch = any
+ license = MIT
+ depends = java-runtime
+ noextract = dumpling-cli-2.4-shaded.jar
+ source = https://repo.maven.apache.org/maven2/com/github/olivergondza/dumpling/dumpling-cli/2.4/dumpling-cli-2.4-shaded.jar
+ md5sums = 941a061edd71b1be9ac7ee708df0df53
+
+pkgname = dumpling
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..89dabf4b6b03
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+dumpling-*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b53bdfe9b9b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Oliver Gondža <ogondza@gmail.com>
+# Contributor: Oliver Gondža <ogondza@gmail.com>
+pkgname=dumpling
+pkgver=2.4
+pkgrel=1
+epoch=0
+pkgdesc="Automation friendly java threaddump analyzer"
+arch=('any')
+url="https://olivergondza.github.io/dumpling/"
+license=('MIT')
+groups=()
+depends=('java-runtime')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(
+ "https://repo.maven.apache.org/maven2/com/github/olivergondza/dumpling/dumpling-cli/$pkgver/dumpling-cli-$pkgver-shaded.jar"
+)
+noextract=("dumpling-cli-$pkgver-shaded.jar")
+md5sums=('941a061edd71b1be9ac7ee708df0df53')
+validpgpkeys=()
+
+package() {
+ install -D -m 644 "dumpling-cli-$pkgver-shaded.jar" "$pkgdir/var/lib/dumpling/dumpling.jar"
+ install -D -m 755 "dumpling" "$pkgdir/usr/bin/dumpling"
+}
diff --git a/build.sh b/build.sh
new file mode 100755
index 000000000000..916cbaad7e26
--- /dev/null
+++ b/build.sh
@@ -0,0 +1,11 @@
+#!/usr/bin/env bash
+# https://github.com/olivergondza/bash-strict-mode
+set -euo pipefail
+trap 's=$?; echo >&2 "$0: Error on line "$LINENO": $BASH_COMMAND"; exit $s' ERR
+
+DIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" >/dev/null && pwd )"
+cd "$DIR"
+
+namcap -i PKGBUILD
+makepkg --printsrcinfo > .SRCINFO
+makepkg -f PKGBUILD
diff --git a/dumpling b/dumpling
new file mode 100644
index 000000000000..a7edf437f5e3
--- /dev/null
+++ b/dumpling
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec java -XX:+TieredCompilation -XX:TieredStopAtLevel=1 -Xmx256M -Xms256M -jar /var/lib/dumpling/dumpling.jar "$@"