summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-09-29 15:28:22 -0500
committerCarlos Aznarán Laos2021-09-29 15:28:22 -0500
commit3f17d723f1556818f23b6fff6968f8dcf5dec016 (patch)
tree1942f9b8e6036dd71c099af2dc3a5720e5d90617
parentc10cbe6311762dcae31e1c9875265fdd16871f94 (diff)
downloadaur-3f17d723f1556818f23b6fff6968f8dcf5dec016.tar.gz
Fix DCMAKE_INSTALL_LIBDIR flag
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b53976d19bcd..a02a1c019e8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = dune-alugrid
pkgrel = 1
url = https://www.dune-project.org/modules/dune-alugrid
arch = x86_64
- license = GPL2
+ license = GPL
makedepends = dune-grid>=2.8.0
makedepends = doxygen
makedepends = graphviz
diff --git a/PKGBUILD b/PKGBUILD
index 7505b6a009c1..641d9fcf16d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgrel=1
pkgdesc="An adaptive, loadbalancing, unstructured implementation of the DUNE grid interface supporting either simplices or cubes"
arch=('x86_64')
url="https://www.dune-project.org/modules/${pkgbase}"
-license=('GPL2')
+license=('GPL')
makedepends=('dune-grid>=2.8.0' 'doxygen' 'graphviz' 'python-setuptools') # 'dlmalloc' 'sionlib' 'parmetis'
optdepends=('doxygen: Generate the class documentation from C++ sources'
'graphviz: Graph visualization software')
@@ -23,7 +23,7 @@ build() {
-B build-cmake \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
-DBUILD_SHARED_LIBS=TRUE \
-DCMAKE_CXX_STANDARD=17 \
-DCMAKE_C_COMPILER=gcc \