summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-09-29 08:07:22 -0500
committerCarlos Aznarán Laos2021-09-29 08:07:22 -0500
commitc10cbe6311762dcae31e1c9875265fdd16871f94 (patch)
treeb1d98988416df2702db673be0fc5d3d8811b851a
parent6c633db944166c23b31e23debb1e7a206983dbe0 (diff)
downloadaur-c10cbe6311762dcae31e1c9875265fdd16871f94.tar.gz
Version bump to 2.8.0, adding python bindings
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD65
2 files changed, 63 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de2e6bb32733..b53976d19bcd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,24 @@
pkgbase = dune-alugrid
- pkgdesc = Unstructured simplicial and cube DUNE grids
- pkgver = 2.6.0
+ pkgdesc = An adaptive, loadbalancing, unstructured implementation of the DUNE grid interface supporting either simplices or cubes
+ pkgver = 2.8.0
pkgrel = 1
- url = https://gitlab.dune-project.org/extensions/dune-alugrid
- arch = i686
+ url = https://www.dune-project.org/modules/dune-alugrid
arch = x86_64
- groups = dune
license = GPL2
- makedepends = git
- makedepends = cmake
- makedepends = dune-common
- makedepends = dune-grid
- makedepends = dune-geometry
- makedepends = openmpi
- makedepends = zlib
- makedepends = metis
- makedepends = parmetis
- source = git+https://gitlab.dune-project.org/extensions/dune-alugrid.git#branch=releases/2.6
- md5sums = SKIP
+ makedepends = dune-grid>=2.8.0
+ makedepends = doxygen
+ makedepends = graphviz
+ makedepends = python-setuptools
+ optdepends = doxygen: Generate the class documentation from C++ sources
+ optdepends = graphviz: Graph visualization software
+ source = https://gitlab.dune-project.org/extensions/dune-alugrid/-/archive/releases/2.8/dune-alugrid-releases-2.8.tar.gz
+ sha512sums = 9dd13a702d35ecf6a4022f70a54227892615a363e7a29b52f9f109c3f1397a6fcd0e43a46821bd92e211dab8c72d68dbe9fa18f30ff1b456e26c1ce1941f8ba8
pkgname = dune-alugrid
+ depends = dune-grid>=2.8.0
+ depends = zoltan
+pkgname = python-dune-alugrid
+ pkgdesc = An adaptive, loadbalancing, unstructured implementation of the DUNE grid interface supporting either simplices or cubes (python bindings)
+ depends = dune-alugrid>=2.8.0
+ depends = python-dune-grid>=2.8.0
diff --git a/PKGBUILD b/PKGBUILD
index e549e03240e2..7505b6a009c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,54 @@
# Maintainer: Josh Hoffer < hoffer dot joshua at gmail dot com >
-pkgname=dune-alugrid
-pkgver=2.6.0
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Lukas Böger <dev___AT___lboeger___DOT___de>
+pkgbase=dune-alugrid
+pkgname=(${pkgbase} python-${pkgbase})
+_tarver=2.8
+_tar="${_tarver}/${pkgbase}-releases-${_tarver}.tar.gz"
+pkgver=${_tarver}.0
pkgrel=1
-pkgdesc='Unstructured simplicial and cube DUNE grids'
-groups=('dune')
-arch=('i686' 'x86_64')
-url='https://gitlab.dune-project.org/extensions/dune-alugrid'
+pkgdesc="An adaptive, loadbalancing, unstructured implementation of the DUNE grid interface supporting either simplices or cubes"
+arch=('x86_64')
+url="https://www.dune-project.org/modules/${pkgbase}"
license=('GPL2')
-makedepends=('git' 'cmake' 'dune-common' 'dune-grid' 'dune-geometry' 'openmpi'
- 'zlib' 'metis' 'parmetis')
+makedepends=('dune-grid>=2.8.0' 'doxygen' 'graphviz' 'python-setuptools') # 'dlmalloc' 'sionlib' 'parmetis'
+optdepends=('doxygen: Generate the class documentation from C++ sources'
+ 'graphviz: Graph visualization software')
+source=(https://gitlab.dune-project.org/extensions/${pkgbase}/-/archive/releases/${_tar})
+sha512sums=('9dd13a702d35ecf6a4022f70a54227892615a363e7a29b52f9f109c3f1397a6fcd0e43a46821bd92e211dab8c72d68dbe9fa18f30ff1b456e26c1ce1941f8ba8')
-source=("git+https://gitlab.dune-project.org/extensions/${pkgname}.git#branch=releases/2.6")
-md5sums=('SKIP')
-
-package() {
-dunecontrol --only=${pkgname} make install DESTDIR="${pkgdir}"
-install -m644 -D ${pkgname}/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-find "${pkgdir}" -type d -empty -delete
+build() {
+ cmake \
+ -S ${pkgbase}-releases-${_tarver} \
+ -B build-cmake \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=TRUE \
+ -DCMAKE_CXX_STANDARD=17 \
+ -DCMAKE_C_COMPILER=gcc \
+ -DCMAKE_CXX_COMPILER=g++ \
+ -DCMAKE_POSITION_INDEPENDENT_CODE=TRUE \
+ -DENABLE_HEADERCHECK=ON \
+ -DDUNE_ENABLE_PYTHONBINDINGS=ON \
+ -DDUNE_PYTHON_INSTALL_LOCATION='none' \
+ -Wno-dev
+ cmake --build build-cmake --target all
+ cd "build-cmake/python"
+ python setup.py build
}
-build() {
-CMAKE_FLAGS='-DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib -fPIC -DBUILD_SHARED_LIBS:BOOL=OFF' \
- dunecontrol configure --enabled-shared
- dunecontrol make
+package_dune-alugrid() {
+ depends=('dune-grid>=2.8.0' 'zoltan')
+ DESTDIR="${pkgdir}" cmake --build build-cmake --target install
+ install -Dm644 ${pkgbase}-releases-${_tarver}/COPYING "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
+ find "${pkgdir}" -type d -empty -delete
}
+package_python-dune-alugrid() {
+ depends=('dune-alugrid>=2.8.0' 'python-dune-grid>=2.8.0')
+ pkgdesc+=" (python bindings)"
+ cd "build-cmake/python"
+ export PYTHONHASHSEED=0
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+}