summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-05 12:41:25 -0500
committerCarlos Aznarán Laos2023-05-05 12:41:25 -0500
commit67abb467e80e89b2a0bf086330ce3b1e3ce66559 (patch)
tree8438c7361b2e2a21bc7c1eef79c5fc1f3acdca1a
parenta50510f8a9a04a4a20f9225d527dd5fc7c1571c1 (diff)
downloadaur-67abb467e80e89b2a0bf086330ce3b1e3ce66559.tar.gz
Python 3.11 rebuild
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2a76e2875e2..5d89871181d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dune-common
pkgdesc = Infrastructure and foundation classes
pkgver = 2.9.0
- pkgrel = 2
+ pkgrel = 3
url = https://dune-project.org/modules/dune-common
arch = x86_64
license = custom:GPL2 with runtime exception
@@ -40,8 +40,12 @@ pkgbase = dune-common
provides = rmgenerated.py
source = https://dune-project.org/download/2.9.0/dune-common-2.9.0.tar.gz
source = https://dune-project.org/download/2.9.0/dune-common-2.9.0.tar.gz.asc
+ source = pybind11-compatibility.patch::https://gitlab.dune-project.org/core/dune-common/-/commit/f3b4ac266d37b7255e68d203dfce4a22bda9b4f1.patch
+ source = gcc13-compatibility.patch::https://gitlab.dune-project.org/core/dune-common/-/commit/56655f6910f3bfcfa86e7573b47228c0f28794f3.patch
validpgpkeys = E5B47782DE09813BCC3518E159DA94F1FC8FD313
sha512sums = 4d1f05ee7d5c2376f0fc782b4978596501eed0e7c6d6c68b3a37949a0141cf308b42a6df1b171804a9606907f6597039f28916731c1caa0c54a36775402e6e97
sha512sums = SKIP
+ sha512sums = af34c7f82db9a03568649090b5ba3c870202619d835341709a3e43aff8649b58bfff69057fecb40fe205bb63d3fff345c066dd965389d29af5c29c80837fd9a7
+ sha512sums = aa0e6cd1af73bee0231dc40cb46081753ed38a3712c30ce79080dbb0023a8d9bacc318b2c5e1e46fa9e8f64a82b4594d2672a00ed178e32f05f3a003e2c9c0f9
pkgname = dune-common
diff --git a/PKGBUILD b/PKGBUILD
index d4b81470878d..0b33702b5d55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=dune-common
_tarver=2.9.0
_tar="${_tarver}/${pkgname}-${_tarver}.tar.gz"
pkgver="${_tarver}"
-pkgrel=2
+pkgrel=3
pkgdesc="Infrastructure and foundation classes"
arch=(x86_64)
url="https://dune-project.org/modules/${pkgname}"
@@ -26,9 +26,13 @@ optdepends=('vc: C++ Vectorization library'
'python-matplotlib: for Matplotlib rendering'
'python-mayavi: for 3D plotting')
provides=('dunecontrol' 'dune-ctest' 'dune-git-whitespace-hook' 'dunepackaging.py' 'duneproject' 'rmgenerated.py')
-source=(https://dune-project.org/download/${_tar}{,.asc})
+source=(https://dune-project.org/download/${_tar}{,.asc}
+ pybind11-compatibility.patch::https://gitlab.dune-project.org/core/${pkgname}/-/commit/f3b4ac266d37b7255e68d203dfce4a22bda9b4f1.patch
+ gcc13-compatibility.patch::https://gitlab.dune-project.org/core/dune-common/-/commit/56655f6910f3bfcfa86e7573b47228c0f28794f3.patch)
sha512sums=('4d1f05ee7d5c2376f0fc782b4978596501eed0e7c6d6c68b3a37949a0141cf308b42a6df1b171804a9606907f6597039f28916731c1caa0c54a36775402e6e97'
- 'SKIP')
+ 'SKIP'
+ 'af34c7f82db9a03568649090b5ba3c870202619d835341709a3e43aff8649b58bfff69057fecb40fe205bb63d3fff345c066dd965389d29af5c29c80837fd9a7'
+ 'aa0e6cd1af73bee0231dc40cb46081753ed38a3712c30ce79080dbb0023a8d9bacc318b2c5e1e46fa9e8f64a82b4594d2672a00ed178e32f05f3a003e2c9c0f9')
validpgpkeys=('E5B47782DE09813BCC3518E159DA94F1FC8FD313') # Andreas Dedner <a.s.dedner@warwick.ac.uk>
prepare() {
@@ -37,6 +41,10 @@ prepare() {
sed -i 's/^Version: '"${pkgver%%.0}"'-git/Version: '"${pkgver}"'/' dune.module
# https://salsa.debian.org/science-team/dune-common/-/blob/master/debian/patches/skip-dirs-starting-with-dot.patch
sed -i 's/^ $(find -H "$dir" -name $CONTROL | $GREP -v '\''dune-\[-_a-zA-Z\]\/dune-\[-a-zA-Z_\]\*-\[0-9\]\\{1,\\}.\[0-9\]\\{1,\\}\/'\'')/ $(find -H "$dir" -name '\''.?\*'\'' -prune -o -name $CONTROL -print | $GREP -v '\''dune-\[-_a-zA-Z\]\/dune-\[-a-zA-Z_\]\*-\[0-9\]\\{1,\\}.\[0-9\]\\{1,\\}\/'\'')/' lib/dunemodules.lib
+ # https://github.com/FEniCS/basix/issues/591
+ patch -p1 -i ../pybind11-compatibility.patch
+ # https://gitlab.dune-project.org/core/dune-common/-/merge_requests/1214
+ patch -p1 -i ../gcc13-compatibility.patch
python -m venv --system-site-packages _skbuild/linux-${CARCH}-${_pyversion}/cmake-build/dune-env
}