summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-11-03 17:57:20 -0500
committerCarlos Aznarán Laos2021-11-03 17:57:20 -0500
commit8cffa59ca109bae6c70f166a3811e8bcb29444db (patch)
tree59c418481ad7d76db56c51c606d64340a3c727b1
parentc4164a18a1461c15a19cd083fc81d267af9d5a49 (diff)
downloadaur-8cffa59ca109bae6c70f166a3811e8bcb29444db.tar.gz
Ensure the lapack is required when build and do not have the error: /usr/sbin/ld: /usr/lib/libdunegeometry.so: undefined reference to
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cdd55fabce1..f47bfbda4021 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = dune-common
pkgdesc = Build system, infrastructure and foundation classes
pkgver = 2.8.0
- pkgrel = 1
+ pkgrel = 2
url = https://dune-project.org/modules/dune-common
arch = x86_64
license = custom:GPL2 with runtime exception
makedepends = cmake
makedepends = openmpi
- makedepends = tbb
+ makedepends = lapack
makedepends = texlive-latexextra
makedepends = biber
makedepends = doxygen
@@ -42,7 +42,6 @@ pkgname = dune-common
depends = python-docutils
depends = git
depends = lapack
- depends = tbb
provides = dune-ctest
provides = duneproject
provides = dunecontrol
diff --git a/PKGBUILD b/PKGBUILD
index 1fa9e09a2765..940548c54b23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,12 @@ pkgname=(${pkgbase} python-${pkgbase})
_tarver=2.8.0
_tar="${_tarver}/${pkgbase}-${_tarver}.tar.gz"
pkgver=${_tarver}
-pkgrel=1
+pkgrel=2
pkgdesc="Build system, infrastructure and foundation classes"
arch=('x86_64')
url="https://dune-project.org/modules/${pkgbase}"
license=('custom:GPL2 with runtime exception')
-makedepends=('cmake' 'openmpi' 'tbb' 'texlive-latexextra' 'biber' 'doxygen' 'graphviz' 'python-sphinx' 'python-setuptools' 'python-portalocker')
+makedepends=('cmake' 'openmpi' 'lapack' 'texlive-latexextra' 'biber' 'doxygen' 'graphviz' 'python-sphinx' 'python-setuptools' 'python-portalocker')
optdepends=('vc: C++ Vectorization library'
'texlive-latexextra: Type setting system'
'doxygen: Generate the class documentation from C++ sources'
@@ -60,7 +60,7 @@ build() {
}
package_dune-common() {
- depends=('cmake' 'openmpi' 'python-docutils' 'git' 'lapack' 'tbb')
+ depends=('cmake' 'openmpi' 'python-docutils' 'git' 'lapack')
provides=('dune-ctest' 'duneproject' 'dunecontrol' 'dunepackaging.py' 'dune-git-whitespace-hook' 'rmgenerated.py' 'setup-dunepy.py')
DESTDIR="${pkgdir}" cmake --build build-cmake --target install sphinx_html
install -d ${pkgdir}/usr/share/doc/${pkgbase}/buildsystem