summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-07-17 18:06:19 -0500
committerCarlos Aznarán Laos2022-07-17 18:06:19 -0500
commitfc7fdf01cca8d3b9d89bba1ba419c8990c785f6c (patch)
tree4ecf1ec4ccf088382766aad20d3ced4a0fd17690
parent7d2ffa91b1c887c0a81cd46aa44d6881420acf10 (diff)
downloadaur-fc7fdf01cca8d3b9d89bba1ba419c8990c785f6c.tar.gz
Add missing dependency python-setuptools, required for packagemetadata.py
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 517a3e728443..8b9c710f389d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dune-common
pkgdesc = Build system, infrastructure and foundation classes
pkgver = 2.8.0
- pkgrel = 5
+ pkgrel = 6
url = https://dune-project.org/modules/dune-common
arch = x86_64
license = custom:GPL2 with runtime exception
@@ -50,5 +50,6 @@ pkgname = python-dune-common
depends = python-portalocker
depends = python-numpy
depends = python-mpi4py
+ depends = python-setuptools
optdepends = python-matplotlib: for Matplotlib rendering
optdepends = mayavi: for 3D plotting
diff --git a/PKGBUILD b/PKGBUILD
index 3864b001b87a..17ddb64900f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=(${pkgbase} python-${pkgbase})
_tarver=2.8.0
_tar="${_tarver}/${pkgbase}-${_tarver}.tar.gz"
pkgver=${_tarver}
-pkgrel=5
+pkgrel=6
pkgdesc="Build system, infrastructure and foundation classes"
arch=('x86_64')
url="https://dune-project.org/modules/${pkgbase}"
@@ -48,7 +48,7 @@ build() {
-DCMAKE_DISABLE_FIND_PACKAGE_PTScotch=TRUE \
-Wno-dev
cmake --build build-cmake --target all
- cd "build-cmake/python"
+ cd build-cmake/python
python setup.py build
}
@@ -74,11 +74,10 @@ package_dune-common() {
}
package_python-dune-common() {
- depends=('dune-common>=2.8.0' 'python-portalocker' 'python-numpy' 'python-mpi4py')
+ depends=('dune-common>=2.8.0' 'python-portalocker' 'python-numpy' 'python-mpi4py' 'python-setuptools')
pkgdesc+=" (python bindings)"
optdepends=('python-matplotlib: for Matplotlib rendering'
'mayavi: for 3D plotting')
- cd "build-cmake/python"
- export PYTHONHASHSEED=0
+ cd build-cmake/python
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
}