summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshH1002019-11-14 10:44:26 -0700
committerJoshH1002019-11-14 10:44:26 -0700
commit8fc84750f7ab98fa79b41a16ad62ae604937635e (patch)
treee622ec48a6b78f3b5abc73bd8411b4c589c9983a
parent92e1886eea856124b84e351d2f63d8794cbd5d8d (diff)
downloadaur-8fc84750f7ab98fa79b41a16ad62ae604937635e.tar.gz
fixed issue with current makepkg
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD61
2 files changed, 32 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 822a9600486d..fc7015512396 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,6 +17,8 @@ pkgbase = dune-core
makedepends = suitesparse
makedepends = parmetis
makedepends = psurface
+ makedepends = python
+ makedepends = bash
source = http://www.dune-project.org/download/2.6.0/dune-common-2.6.0.tar.gz
source = http://www.dune-project.org/download/2.6.0/dune-geometry-2.6.0.tar.gz
source = http://www.dune-project.org/download/2.6.0/dune-localfunctions-2.6.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 07df3bbac2af..48cb656499d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,8 @@
# Maintainer: Josh Hoffer < hoffer dot joshua at gmail dot com >
pkgbase=dune-core
pkgname=('dune-common' 'dune-geometry' 'dune-localfunctions' 'dune-istl' 'dune-grid' 'dune-uggrid')
-
pkgver=2.6.0
pkgrel=1
-export CPPFLAGS="-I/usr/include/tirpc ${CPPFLAGS}"
pkgdesc='Core modules of the DUNE framework'
groups=('dune')
url='http://www.dune-project.org'
@@ -13,9 +11,9 @@ arch=('i686' 'x86_64')
license=('custom')
makedepends=('cmake' 'gcc-fortran' 'openmpi' 'gmp' 'lapack' 'boost' 'superlu' 'suitesparse'
- 'parmetis' 'psurface' )
-
+ 'parmetis' 'psurface' 'python' 'bash')
+export CPPFLAGS="-I/usr/include/tirpc ${CPPFLAGS}"
export CFLAGS="-fPIC ${CFLAGS}"
export CXXFLAGS="-fPIC ${CFLAGS}"
@@ -32,13 +30,13 @@ md5sums=('fb21de7469a2c2cbff6ec7439891c7d6'
_dunecontrol="./dune-common-${pkgver}/bin/dunecontrol"
-prepare() {
- cd "dune-istl-${pkgver}"
+#prepare() {
+# cd "dune-istl-${pkgver}"
# patch -p1 -i ../../avoid-boost-fusion-1.61.patch
-}
+#}
-package() {
+make_package() {
$_dunecontrol --only=${pkgname} make install DESTDIR="${pkgdir}"
install -m644 -D ${pkgname}-${pkgver}/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
@@ -57,51 +55,52 @@ package_dune-common() {
pkgdesc='Basic classes used by all DUNE modules'
depends=('bash' 'python')
- package
+ make_package
}
package_dune-geometry() {
pkgdesc='Reference elements with corresponding mappings and quadratures'
- package
+ make_package
}
package_dune-localfunctions() {
pkgdesc='Shape functions, interpolation operators on DUNE reference elemements'
arch=('any')
- package
+ make_package
+}
+
+package_dune-istl() {
+ pkgdesc='Iterative solver template library'
+ arch=('any')
+
+ make_package
}
package_dune-grid() {
pkgdesc='Nonconforming, hierarchically nested, multi-element-type, parallel grids'
arch=('any')
- package
+ make_package
}
package_dune-uggrid() {
pkgdesc='UG grid manager'
arch=('any')
- package
+ make_package
}
-package_dune-istl() {
- pkgdesc='Iterative solver template library'
- arch=('any')
- package
-}
-
-package_dune-alugrid() {
- pkgdesc='Unstructured simplicial and cube DUNE grids'
- arch=('any')
-
- package
-}
-package_dune-functions() {
- pkgdesc='Needed to build core dune modules'
- arch=('any')
-
- package
-}
+#package_dune-alugrid() {
+# pkgdesc='Unstructured simplicial and cube DUNE grids'
+# arch=('any')
+#
+# package
+#}
+#package_dune-functions() {
+# pkgdesc='Needed to build core dune modules'
+# arch=('any')
+#
+# package
+#}