summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Böger2016-10-07 10:37:25 +0200
committerLukas Böger2016-10-07 10:37:25 +0200
commit97db4b9ec0879f0e339861dbbb151eebba455354 (patch)
treef386b4b538fa270fa48314fe96bc96ab7a62c739
parentd99a1f17f539fd2b11c06b078592e6659d4d638a (diff)
downloadaur-97db4b9ec0879f0e339861dbbb151eebba455354.tar.gz
apply upstream patch for compilation with boost-1.61
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
-rw-r--r--avoid-boost-fusion-1.61.patch28
3 files changed, 36 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e372698aa141..d96ba0499610 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dune-core
pkgdesc = Core modules of the DUNE framework
pkgver = 2.4.1
- pkgrel = 2
+ pkgrel = 3
url = http://www.dune-project.org
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 4aa98cb967b3..be033c16bbbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase=dune-core
pkgname=('dune-common' 'dune-geometry' 'dune-localfunctions' 'dune-grid' 'dune-istl')
pkgver=2.4.1
-pkgrel=2
+pkgrel=3
pkgdesc='Core modules of the DUNE framework'
groups=('dune')
@@ -30,6 +30,12 @@ md5sums=(
_dunecontrol="./dune-common-${pkgver}/bin/dunecontrol --use-cmake"
+prepare() {
+ cd "dune-istl-${pkgver}"
+
+ patch -p1 -i ../../avoid-boost-fusion-1.61.patch
+}
+
package() {
$_dunecontrol --only=${pkgname} make install DESTDIR="${pkgdir}"
diff --git a/avoid-boost-fusion-1.61.patch b/avoid-boost-fusion-1.61.patch
new file mode 100644
index 000000000000..868ac71406f1
--- /dev/null
+++ b/avoid-boost-fusion-1.61.patch
@@ -0,0 +1,28 @@
+diff --git a/dune/istl/tutorial/example.cc b/dune/istl/tutorial/example.cc
+index cc52ba8..46719b2 100644
+--- a/dune/istl/tutorial/example.cc
++++ b/dune/istl/tutorial/example.cc
+@@ -508,6 +508,14 @@ void test_Interface ()
+
+
+ #ifdef HAVE_BOOST_FUSION
++#include <boost/version.hpp>
++#if BOOST_VERSION < 106100
++#define HAVE_USABLE_BOOST_FUSION
++#endif
++#endif
++
++#ifdef HAVE_USABLE_BOOST_FUSION
++
+
+ void test_MultiTypeBlockVector_MultiTypeBlockMatrix() { //Jacobi Solver Test MultiTypeBlockMatrix_Solver::dbjac on MultiTypeBlockMatrix<BCRSMatrix>
+
+@@ -612,7 +620,7 @@ int main (int /*argc*/, char ** /*argv*/)
+ test_IO();
+ test_Iter();
+ test_Interface();
+-#ifdef HAVE_BOOST_FUSION
++#ifdef HAVE_USABLE_BOOST_FUSION
+ test_MultiTypeBlockVector_MultiTypeBlockMatrix();
+ #endif
+ }