summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas K.2024-01-19 00:09:13 +0100
committerLukas K.2024-01-19 00:09:13 +0100
commit6613e352d9537b5571fcfee3ce472548678471fe (patch)
tree46c84f493a5300c4df9687d4c5817a8db21b8b48
downloadaur-6613e352d9537b5571fcfee3ce472548678471fe.tar.gz
version 0.9.3
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD30
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..992d21daa3c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Thu Jan 18 23:07:49 UTC 2024
+pkgbase = dune3d
+ pkgdesc = Parametric 3D CAD
+ pkgver = 0.9.3
+ pkgrel = 1
+ url = https://dune3d.org
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = glm
+ makedepends = python3
+ makedepends = librsvg
+ makedepends = meson
+ makedepends = cmake
+ makedepends = python-gobject
+ makedepends = python-cairo
+ depends = gtkmm-4.0
+ depends = cairomm
+ depends = opencascade
+ depends = eigen
+ depends = libspnav
+ source = https://github.com/dune3d/dune3d/archive/v0.9.3.tar.gz
+ sha256sums = 8716013cf89d240acceb75a1c33fac4027734d37f01362766895c1eea9096bb0
+
+pkgname = dune3d
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bf5e1c0456f6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src
+pkg
+*.tar.xz
+*.tar.gz
+*.patch
+horizon
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1956c0d5d662
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Lukas K. <lu@0x83.eu>
+
+pkgname=dune3d
+pkgver=0.9.3
+pkgrel=1
+pkgdesc="Parametric 3D CAD"
+arch=('x86_64' 'i686')
+url="https://dune3d.org"
+license=('GPL')
+depends=('gtkmm-4.0' 'cairomm' 'opencascade' 'eigen' 'libspnav')
+makedepends=('glm' 'python3' 'librsvg' 'meson' 'cmake' 'python-gobject' 'python-cairo')
+source=(
+ "https://github.com/dune3d/dune3d/archive/v${pkgver}.tar.gz"
+)
+sha256sums=(
+ '8716013cf89d240acceb75a1c33fac4027734d37f01362766895c1eea9096bb0'
+)
+
+build() {
+ cd dune3d-$pkgver
+ arch-meson build
+
+ cd build
+ ninja
+}
+
+package() {
+ cd dune3d-$pkgver/build
+ DESTDIR="$pkgdir" ninja install
+}