summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2023-06-15 02:04:03 +0200
committerCarsten Teibes2023-06-15 02:04:03 +0200
commit84ad6a09a5fc43bab06fee54cd37b6797c04e382 (patch)
treedd8a707a23fa85c1782d1a16770bea77740da4c4
parentb37cba3f8b70b5c3f9d7ab4a7d9427d225048018 (diff)
downloadaur-84ad6a09a5fc43bab06fee54cd37b6797c04e382.tar.gz
[fix] sdl2 dependencies
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
-rw-r--r--dunelegacy-git.install2
3 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92569cf9d7a4..c90daed2aa2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dunelegacy-git
pkgdesc = Updated clone of Westood Studios' Dune2 (development version)
- pkgver = 0.96.3.r8.g319cb34
+ pkgver = 0.96.4.r168.g6ea9ac9
pkgrel = 1
url = http://dunelegacy.sourceforge.net
install = dunelegacy-git.install
@@ -8,11 +8,11 @@ pkgbase = dunelegacy-git
arch = x86_64
license = GPL2
makedepends = git
- depends = sdl_mixer
+ depends = sdl2_mixer
+ depends = sdl2_ttf
provides = dunelegacy
conflicts = dunelegacy
source = dunelegacy::git+http://git.code.sf.net/p/dunelegacy/code
md5sums = SKIP
pkgname = dunelegacy-git
-
diff --git a/PKGBUILD b/PKGBUILD
index bee3bcba53c4..6cfa20a40162 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
-# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
_pkgbase=dunelegacy
pkgname=$_pkgbase-git
-pkgver=0.96.3.r8.g319cb34
+pkgver=0.96.4.r168.g6ea9ac9
pkgrel=1
pkgdesc="Updated clone of Westood Studios' Dune2 (development version)"
arch=('i686' 'x86_64')
url="http://dunelegacy.sourceforge.net"
license=('GPL2')
-depends=('sdl_mixer')
+depends=('sdl2_mixer' 'sdl2_ttf')
makedepends=('git')
conflicts=("$_pkgbase")
provides=("$_pkgbase")
@@ -21,20 +21,31 @@ pkgver() {
git describe --long --tags | sed 's/v//;s/-/.r/;s/-/./g'
}
+prepare() {
+ cd $_pkgbase
+
+ autoreconf -fi
+
+ # fix compilation, if needed
+ grep -q "<array>" include/FileClasses/TextManager.h ||
+ sed '/^#include <string>/i #include <array>' -i include/FileClasses/TextManager.h
+}
+
build() {
cd $_pkgbase
- autoreconf --install
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --enable-silent-rules
make
}
package() {
cd $_pkgbase
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir" install
- # install icon and desktop files
+ # install icons and .desktop file
install -Dm644 $_pkgbase.png "$pkgdir"/usr/share/pixmaps/$_pkgbase.png
+ install -Dm644 $_pkgbase-128x128.png "$pkgdir"/usr/share/icons/hicolor/128x128/apps/$_pkgbase.png
+ install -Dm644 $_pkgbase.svg "$pkgdir"/usr/share/icons/hicolor/scalable/apps/$_pkgbase.svg
install -Dm644 $_pkgbase.desktop "$pkgdir"/usr/share/applications/$_pkgbase.desktop
}
diff --git a/dunelegacy-git.install b/dunelegacy-git.install
index 027bf00a3774..06ffb20ae0c7 100644
--- a/dunelegacy-git.install
+++ b/dunelegacy-git.install
@@ -1,6 +1,6 @@
post_install() {
- echo "Remember you have to put your DUNEII datafiles under ~/.config/dunelegacy/data/"
+ echo "Remember you have to put your DUNE II datafiles under ~/.config/dunelegacy/data/"
}
post_upgrade() {