summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonis G2015-10-07 09:49:51 +0300
committerAntonis G2015-10-07 09:49:51 +0300
commit0977df7f77eef51717508e897de8bff10ffd86b4 (patch)
treee05101a474ef9d6af9ad97b8eff7c7d423416b83
downloadaur-0977df7f77eef51717508e897de8bff10ffd86b4.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
-rw-r--r--dungeon-gdt-glk.patch26
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fac799975633
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = dungeon-gdt-glk
+ pkgdesc = Dungeon is the original Zork text adventure.
+ pkgver = 3.2
+ pkgrel = 1
+ url = http://gunkies.org/wiki/Zork
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = make
+ depends = glkterm
+ provides = dungeon
+ provides = dungeon-glk
+ conflicts = dungeon
+ conflicts = dungeon-glk
+ source = http://www.ifarchive.org/if-archive/games/source/dungeon-gdt-glk.tar.gz
+ source = dungeon-gdt-glk.patch
+ sha256sums = d6587be3f10dda85e152bb6c17966157bc9378f4ad6013b81b9fd285fd122032
+ sha256sums = f43151034031bcb6881802b3a4ee739302adc3ce8c7497f93b20262d13603178
+
+pkgname = dungeon-gdt-glk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c594cb661423
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Antonis Geralis <capoiosct@gmail.com>
+
+_pkgname=dungeon
+pkgname=dungeon-gdt-glk
+pkgver=3.2
+pkgrel=1
+pkgdesc="Dungeon is the original Zork text adventure."
+arch=('i686' 'x86_64')
+url="http://gunkies.org/wiki/Zork"
+license=('custom')
+depends=('glkterm')
+makedepends=('make')
+provides=("${_pkgname}" "${_pkgname}-glk")
+conflicts=("${_pkgname}" "${_pkgname}-glk")
+source=("http://www.ifarchive.org/if-archive/games/source/${pkgname}.tar.gz" "${pkgname}.patch")
+sha256sums=('d6587be3f10dda85e152bb6c17966157bc9378f4ad6013b81b9fd285fd122032'
+ 'f43151034031bcb6881802b3a4ee739302adc3ce8c7497f93b20262d13603178')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-gdt"
+ patch -Np1 -i ../${pkgname}.patch
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-gdt"
+ make dungeon
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-gdt"
+ # executable
+ install -Dm755 dungeon "${pkgdir}/usr/bin/${_pkgname}"
+ # data file
+ install -Dm644 dundat "${pkgdir}/usr/share/${_pkgname}/dundat"
+ # license
+ install -d "${pkgdir}/usr/share/licenses/${_pkgname}"
+ grep -A 25 'Copyrights and Other Verbiage' README > "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
diff --git a/dungeon-gdt-glk.patch b/dungeon-gdt-glk.patch
new file mode 100644
index 000000000000..e2dd5dee5ac8
--- /dev/null
+++ b/dungeon-gdt-glk.patch
@@ -0,0 +1,26 @@
+--- dungeon-gdt/Makefile 2009-11-25 21:44:23.000000000 +0200
++++ dungeon-gdt/Makefile 2015-10-07 07:50:06.162619426 +0300
+@@ -9,8 +9,8 @@
+ #GLKLIBDIR = ../cheapglk
+ #GLKMAKEFILE = Make.cheapglk
+
+-GLKINCLUDEDIR = ../glkterm
+-GLKLIBDIR = ../glkterm
++GLKINCLUDEDIR = /usr/include
++GLKLIBDIR = /usr/lib
+ GLKMAKEFILE = Make.glkterm
+
+ #GLKINCLUDEDIR = ../xglk
+@@ -25,10 +25,10 @@
+ # next line to a directory that suits you, and then copy the "dundat"
+ # file into that directory. Otherwise, the game will look for "dundat"
+ # in the current directory.
+-DATADIR = .
++DATADIR = /usr/share/dungeon
+
+ # To include the in-game debugger, uncomment the following line:
+-# GDT_FLAG = -DHAVE_GDT=1
++GDT_FLAG = -DHAVE_GDT=1
+
+ OPTIONS = -g -Wall -Wmissing-prototypes -Wstrict-prototypes -Wno-unused
+