summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoviuro2018-07-22 11:01:27 +0200
committerMoviuro2018-07-22 11:01:27 +0200
commita891f6532afcb91f9925b92d81163c2a83ce4973 (patch)
tree50f68da316cd4f8a2cfc0cd6810343db764b7543
downloadaur-a891f6532afcb91f9925b92d81163c2a83ce4973.tar.gz
dungeons-2-gog: first introduction to AUR
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD68
-rw-r--r--dungeons-2-gog.desktop12
-rw-r--r--dungeons-2-gog.in4
4 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e77b57139b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = dungeons-2-gog
+ pkgdesc = The Dungeon Lord is back – and this time he’s serious!
+ pkgver = 2.0.0.1
+ pkgrel = 1
+ url = http://www.gog.com/game/dungeons_2
+ arch = x86_64
+ license = custom:commercial
+ depends = libx11
+ depends = libxcursor
+ depends = libxrandr
+ depends = libglvnd
+ depends = libxext
+ depends = libxcb
+ depends = libxrender
+ depends = libxfixes
+ depends = libxau
+ depends = libxdmcp
+ source = dungeons-2-gog.desktop
+ source = dungeons-2-gog.in
+ source = gog_dungeons_2_2.0.0.1.sh::file://gog_dungeons_2_2.0.0.1.sh
+ sha256sums = e28ce7cacca9d7585b557f8f946696d93f2640924e74770f82d2841e039310ea
+ sha256sums = ce8cd95969a904b55ec3626fe0b01d89510a26fece6043eefa4331127d9169f8
+ sha256sums = e9ab64e2f428201e22b1ee445e559898746b9249335d1c4765b50a40597559aa
+
+pkgname = dungeons-2-gog
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5bf75643bbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Moviuro <moviuro+aur at gmail dot com>
+
+pkgname=dungeons-2-gog
+pkgver=2.0.0.1
+pkgrel=1
+pkgdesc="The Dungeon Lord is back – and this time he’s serious!"
+arch=("x86_64")
+url="http://www.gog.com/game/dungeons_2"
+license=("custom:commercial")
+depends=("libx11" "libxcursor" "libxrandr" "libglvnd" "libxext" "libxcb"
+ "libxrender" "libxfixes" "libxau" "libxdmcp")
+source=("${pkgname}.desktop"
+ "${pkgname}.in"
+ "gog_dungeons_2_${pkgver}.sh::file://gog_dungeons_2_${pkgver}.sh")
+sha256sums=("e28ce7cacca9d7585b557f8f946696d93f2640924e74770f82d2841e039310ea"
+ "ce8cd95969a904b55ec3626fe0b01d89510a26fece6043eefa4331127d9169f8"
+ "e9ab64e2f428201e22b1ee445e559898746b9249335d1c4765b50a40597559aa")
+
+# Disable compression of the package
+PKGEXT='.pkg.tar'
+
+package() {
+ # Data
+ # Hardlink files to save the disk space and time spent copying them (they are large)
+ mkdir -p "$pkgdir/opt/$pkgname/game/"
+ cp -Ral -t "$pkgdir/opt/$pkgname/game/" "$srcdir/data/noarch/game/"*
+ find "$pkgdir/opt/$pkgname/game/" -type d -print0 | xargs -0 chmod 755
+ find "$pkgdir/opt/$pkgname/game/" -type f -print0 | xargs -0 chmod 644
+ chmod 755 "$pkgdir/opt/$pkgname/game/mono/bin/mono"
+ chmod 755 "$pkgdir/opt/$pkgname/game/Dungeons2.x86_64"
+
+ # Remove a pointless broken script
+ rm "$pkgdir/opt/$pkgname/game/Dungeons2"
+
+ # Docs
+ install -m755 -d "$pkgdir/opt/$pkgname/docs/"
+ find "$srcdir/data/noarch/docs/" -maxdepth 1 -type f -print0 | \
+ xargs -0 install -m644 -t "$pkgdir/opt/$pkgname/docs/"
+
+ # Icon
+ install -m755 -d "$pkgdir/opt/$pkgname/"
+ install -m644 -t "$pkgdir/opt/$pkgname/" "$srcdir/data/noarch/support/icon.png"
+
+ #
+ # System integration
+ #
+
+ # /bin
+ install -m755 -d "$pkgdir/usr/bin/"
+ sed "s!@PKGDEST@!/opt/$pkgname/game/!" "$pkgname.in" > "$pkgdir/usr/bin/$pkgname"
+ chmod 755 "$pkgdir/usr/bin/$pkgname"
+
+ # License
+ install -m755 -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s "/opt/$pkgname/docs/End User License Agreement.txt" "$pkgdir/usr/share/licenses/$pkgname/EULA"
+
+ # Icon
+ install -m755 -d "$pkgdir/usr/share/pixmaps/"
+ ln -s "/opt/$pkgname/icon.png" "$pkgdir/usr/share/pixmaps/${pkgname}.png"
+
+ # .desktop File
+ install -m755 -d "$pkgdir/usr/share/applications/"
+ install -m644 -t "$pkgdir/usr/share/applications/" "$srcdir/${pkgname}.desktop"
+
+ # Doc
+ install -m755 -d "$pkgdir/usr/share/doc/"
+ ln -s "/opt/$pkgname/docs" "$pkgdir/usr/share/doc/$pkgname"
+}
diff --git a/dungeons-2-gog.desktop b/dungeons-2-gog.desktop
new file mode 100644
index 000000000000..8b0e2e8be94e
--- /dev/null
+++ b/dungeons-2-gog.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Icon=/usr/share/pixmaps/dungeons-2-gog.png
+Exec=/usr/bin/dungeons-2-gog
+Terminal=false
+StartupNotify=false
+
+Name=Dungeons 2
+Comment=The Dungeon Lord is back – and this time he’s serious!
+
+Categories=Game;
diff --git a/dungeons-2-gog.in b/dungeons-2-gog.in
new file mode 100644
index 000000000000..57dc69248dca
--- /dev/null
+++ b/dungeons-2-gog.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd @PKGDEST@
+./Dungeons2.x86_64 "$@"